Fehler bei ungültigen Anmeldeinformationen beim Desktopfluss, wenn Sie ein Microsoft Entra-Konto verwenden
Dieser Artikel enthält eine Lösung für den Fehlercode, WindowsIdentityIncorrect
der InvalidConnectionCredentials
auftritt, wenn Sie einen Desktopfluss mit einem Microsoft Entra-Konto ausführen.
Gilt für: Power Automate
Ursprüngliche KB-Nummer: 4555623
Symptome
Wenn Sie einen Desktopfluss mit einem Microsoft Entra-Konto ausführen, schlägt er mit dem InvalidConnectionCredentials
Code oder WindowsIdentityIncorrect
dem Fehlercode fehl.
{
"error":{
"code": "InvalidConnectionCredentials",
"message": "Could not connect to the Power Automate UI flows Agent. Please make sure that the UI flows connection credentials are valid."
}
}
{
"error":{
"code": "WindowsIdentityIncorrect",
"message": "The credentials provided with the request are invalid."
}
}
Ursache
Möglicherweise tritt der Fehler auf, wenn Sie ein Microsoft Entra-Konto aus mehreren Gründen verwenden:
- Die in die Verbindung eingegebenen Kontoanmeldeinformationen stimmen möglicherweise nicht mit den Anmeldeinformationen auf dem Computer überein.
- Das Gerät ist möglicherweise nicht mit Microsoft Entra verbunden oder microsoft Entra hybrid eingebunden, um die Microsoft Entra-Authentifizierung zu unterstützen.
- Das Microsoft Entra-Konto wird möglicherweise nicht mit dem Computer synchronisiert.
Lösung
Stellen Sie sicher, dass das Gerät mit Microsoft Entra verbunden ist oder einer Domäne beigetreten ist:
Öffnen Sie eine Eingabeaufforderung.
Führen Sie den Befehl
dsregcmd /status
aus.Überprüfen Sie den
Device State
Abschnitt.Stellen Sie sicher, dass einer der
DomainJoined
WerteAzureAdJoined
YES
ist.Wenn dies nicht der Fall ist, kann ein Microsoft Entra-Konto nur verwendet werden, wenn das Gerät verbunden ist. Weitere Informationen finden Sie unter "Verbinden eines Geräts".
Identifizieren Sie das Microsoft Entra-Konto, das in der Computerkonfiguration verwendet werden soll:
Öffnen Sie "Einstellungen", und wählen Sie "Konten" aus.
Wählen Sie "Auf Arbeit oder Schule zugreifen" aus.
Stellen Sie sicher, dass Text wie "Mit your_organization> Microsoft Entra ID verbunden<" angezeigt wird. Das Konto, mit dem es verbunden ist, kann in der Verbindung verwendet werden.
Synchronisieren Sie das Microsoft Entra-Konto auf dem Gerät:
Wählen Sie die Schaltfläche "Info " aus, wenn Sie Ihre Microsoft Entra-Verbindung auf der Access-Geschäfts-, Schul- oder Uniseite auswählen.
Dadurch wird eine Seite geöffnet, die Ihre Verbindungsinformationen und den Gerätesynchronisierungsstatus beschreibt. Wählen Sie die Schaltfläche "Synchronisieren " am Ende der Seite aus, und warten Sie, bis dieser Vorgang abgeschlossen ist.
Stellen Sie sicher, dass sich das konfigurierte Microsoft Entra-Konto bei dem Gerät anmelden kann:
- Versuchen Sie, sich mit dem in Schritt 2 identifizierten Microsoft Entra-Konto beim Computer anzumelden.
- Die Geräteanmeldung muss erfolgreich sein, um in einer Verbindung verwendet zu werden.
Stellen Sie sicher, dass der Fluss ordnungsgemäß mit dem richtigen Benutzernamen und Kennwort konfiguriert ist. Dies muss mit dem Konto auf Ihrem Computer übereinstimmen.