Behandlung bekannter Probleme mit Prognosen
Dieser Artikel hilft Ihnen bei der Behandlung und Behebung von Problemen im Zusammenhang mit der Prognose in Microsoft Dynamics 365 Sales.
Problem 1 – Ein Fehler wird angezeigt, wenn Sie versuchen, eine gebietsbasierte Prognose zu erstellen.
Problembeschreibung
Wenn Sie versuchen, eine gebietsbasierte Prognose zu erstellen, wird ein Fehler angezeigt. Außerdem werden die Daten in einer gebietsbasierten Prognose möglicherweise nicht aktualisiert.
Ursache
Wenn Systemupdates ausgeführt werden, wird die Hierarchie der Gebietsentität deaktiviert (obwohl Sie es zuvor aktiviert haben), was diesen Fehler verursacht.
Lösung
Um dieses Problem zu beheben, müssen Sie die Hierarchie in der territory_parent_territory Beziehungsdefinition aus Beziehungen aktivieren. Führen Sie folgende Schritte aus:
Wechseln Sie zu " Einstellungen im Voraus".
Die Seite "Einstellungen im Voraus" wird auf einer Registerkarte geöffnet.
Wählen Sie Anpassungen der Einstellungen>aus.>
Die Seite "Power Apps-Einstellungen " wird geöffnet.
Wählen Sie "Datenentitäten>" und dann "Gebiet" aus.
Wählen Sie auf der Seite "Gebiet " die Registerkarte "Beziehungen " und dann " Übergeordnetes Element" aus.
Aktivieren Sie im Dialogfeld "n:1" das Kontrollkästchen "Hierarchisch", und wählen Sie dann "Fertig" aus.
Speichern und schließen Sie die Entität.
Problem 2 – Das Feld "Prognosekategorie" kann nicht in Verkaufschancenformularen ausgeblendet werden.
Ursache
Manchmal zeigt die App das Feld "Prognosekategorie " in Verkaufschancenformularen an, auch wenn sie standardmäßig durch Formularanpassungen als unsichtbar konfiguriert wurde.
Lösung
Um diesen Fehler zu beheben, müssen Sie das Feld "Prognosekategorie " aus dem Formular löschen. Führen Sie folgende Schritte aus:
In Ihrer App auf der Navigationsleiste wählen Sie Einstellungen und wählen Sie dann Erweiterte Einstellungen aus.
Die Seite Unternehmensmanagementeinstellungen wird geöffnet in einer neuen Browserregisterkarte.
Wählen Sie auf der Navigationsleiste "Einstellungen" und dann unter "Anpassung" die Option "Anpassungen" aus.
Wählen Sie System anpassen aus.
Erweitern Sie unter "Komponenten" im Projektmappen-Explorer "Entitäten", "Verkaufschance" und wählen Sie dann "Formulare" aus.
Öffnen Sie das Verkaufschancenformular des Formulartyps "Main".
Das Verkaufschancenformular wird in einem neuen Fenster geöffnet.
Wählen Sie im Abschnitt "Zusammenfassung " das Feld "Prognosekategorie " und dann " Entfernen" aus.
Speichern und veröffentlichen Sie die Konfiguration.
Problem 3 – Prognosen können nicht angezeigt werden
Ursache
Wenn Sie die vorherige Version der Prognose verwendet und auf die neueste Version aktualisiert haben, wird die Prognosewebsitekarte möglicherweise nicht aktualisiert. Dies kann durch das Vorhandensein einer nicht verwalteten Ebene der Sales Hub-App verursacht werden, wodurch die Prognosewebsitekarte die vorherige Version der Prognoseplanung öffnen kann.
Die folgende Abbildung ist ein Beispiel für die vorherige Version der Startseite der Prognose.
Lösung
Um dieses Problem zu beheben, aktualisieren Sie den Karteneintrag für die Prognosewebsite auf das neueste Prognoseeintragsraster. Weitere Informationen finden Sie unter Hinzufügen von Prognoseraster- und Konfigurationsoptionen in der Websitekarte.
Problem 4 : Das Prognoseraster kann nicht geladen werden, und es wird ein Fehler angezeigt.
Ursache
Der ForecastInstanceActions-Prozess wird deaktiviert. Der Grund kann sein, dass sich der Besitzer einer Organisation geändert hat, was dazu führt, dass das Prognoseraster nicht geladen wird. Der in der folgenden Abbildung gezeigte Fehler wird angezeigt.
Aktion (ForecastInstanceActions) zum Abrufen von Prognosen wurde deaktiviert.
Lösung
Um diesen Fehler zu beheben, aktivieren Sie den ForecastInstanceActions-Prozess . Führen Sie folgende Schritte aus:
Wechseln Sie zu "Erweiterte Einstellungen", und wählen Sie dann "Prozesscenterprozesse>">aus.
Geben Sie im Suchfeld "ForecastInstanceActions" ein. Sie können sehen, dass sich der Prozess im Entwurfszustand befindet.
Wählen Sie den Prozess und dann "Aktivieren" aus.
Wählen Sie Aktivieren in der Bestätigungsmeldung aus.
Überprüfen Sie, ob der Prozessstatus aktiviert ist, und schließen Sie dann "Einstellungen".
Problem 5 – Drilldowndaten in einem Prognoseraster können nicht angezeigt werden
Ursache
Sie verfügen nicht über ausreichende Berechtigungen für die Prognosekonfigurationsentität , um Drilldowndaten im Prognoseraster anzuzeigen. Der in der folgenden Abbildung gezeigte Fehler wird angezeigt.
Es ist ein Problem aufgetreten.
Fehler beim Abrufen der Prognosedatensätze.
Laden Sie die Browserseite erneut neu.
Lösung
Um diesen Fehler zu beheben, muss Ihr Administrator Leseberechtigungen für die Prognosekonfigurationsentität für Ihre Sicherheitsrolle bereitstellen. Führen Sie folgende Schritte aus:
Wechseln Sie zu "Erweiterte Einstellungen", und wählen Sie dann "Sicherheitsrollen> für Einstellungen">aus.
Wählen Sie die Sicherheitsrolle aus, für die Sie die Berechtigungen anwenden möchten.
Wählen Sie auf der Seite "Sicherheitsrolle" die Registerkarte "Benutzerdefinierte Entitäten " aus, und wechseln Sie zur Zeile "Prognosekonfiguration ".
Wählen Sie die Leseberechtigungen aus, und geben Sie sie an.
Schließen Sie die Einstellungen.
Problem 6 – Prognosekategoriefelder werden nicht aktualisiert
Ursache
In einer Prognose werden nach dem Aktualisieren des Felds "Prognosekategorie" auf "Gewonnen" oder "Verloren" die Verkaufschancen weiterhin im vorherigen Pipeline-Bucket angezeigt. Dieser Fehler tritt auf, da der Workflow für die Zuordnung von Kategorien der Verkaufschanceprognosen in Ihrer Organisation deaktiviert ist.
Lösung
Um den Fehler zu beheben, aktivieren Sie den Workflow für die Zuordnung von Kategoriezuordnungsprozess für Verkaufschancenprognosen. Führen Sie folgende Schritte aus:
Wechseln Sie zu "Erweiterte Einstellungen", und wählen Sie dann "Einstellungenanpassungen>>anpassen" aus.
Wählen Sie in der Sitemap "Prozesse" aus.
Wählen Sie den Workflow für die Zuordnung der Kategoriezuordnung von Verkaufschancenprognosen und dann " Aktivieren" aus.
Die Prognosekategorien in den Verkaufschancen werden ordnungsgemäß aktualisiert. Die Möglichkeiten, die vor der Aktivierung des Workflows geändert wurden, müssen manuell geändert werden. Öffnen Sie außerdem den Workflow für die Zuordnung von Verkaufschancenprognosen, und stellen Sie sicher, dass die Bedingungen für jede Prognosekategorie ordnungsgemäß definiert sind.
Speichern und schließen Sie die Einstellungen.
Problem 7 – Eine Prognose mit einer hierarchiebezogenen Spalte des Nachschlagetyps kann nicht aktiviert werden.
Ursache
Dieses Problem tritt auf, da der Benutzer "Dynamics 365 Sales Forecasting" nicht über die Leseberechtigung für die hierarchiebezogene Nachschlageentität verfügt.
Lösung
Führen Sie die Schritte aus, um das Problem zu lösen:
Wechseln Sie zu "Erweiterte Einstellungen", und wählen Sie "Systemsicherheitsrollen>">>aus.
Öffnen Sie die Rolle "Prognose-AppUser ", und wählen Sie die Registerkarte aus, auf der der Entitätstyp vorhanden ist.
Aktivieren Sie die Leseberechtigung auf Organisationsebene für den Entitätstyp des Nachschlagefelds.
Speichern Sie die Änderungen.
Problem 8 – Eine Prognose kann nicht aktiviert werden
Ursache
Die Prognoseaktivierung schlägt aus mehreren Gründen fehl.
Lösung
Führen Sie die Schritte aus, um das Problem zu lösen:
- Stellen Sie sicher, dass Sie alle obligatorischen Konfigurationen für Ihr Prognosemodell durchgeführt haben.
- Stellen Sie sicher, dass Hierarchiefilter in der Prognosekonfiguration nicht die gesamte Hierarchie herausfiltern. Wechseln Sie im Allgemeinen Schritt zum Abschnitt "Vorschau", um sicherzustellen, dass die Hierarchie vorhanden ist. Weitere Informationen finden Sie unter Hinzufügen zusätzlicher Filter zu einer Prognose.
Problem 9 – Die Prognosekonfigurationsoption kann in den App-Einstellungen nicht gefunden werden.
Ursache
Die Prognosekonfigurationsoption ist möglicherweise aufgrund der folgenden Gründe in den App-Einstellungen der Sales Hub-App nicht sichtbar:
- Sie verfügen nicht über die Leseberechtigung für die Prognosekonfigurationsentität.
- Ihr Administrator hat das Prognoseraster und die Konfiguration nicht manuell im Abschnitt "Leistungsverwaltung" hinzugefügt.
Lösung
Führen Sie die folgenden Schritte aus, um das Problem zu beheben:
- Weisen Sie dem Benutzer die Sicherheitsrolle Prognose-Manager zu, die in der Lage sein soll, Prognosekonfigurationen zu erstellen und zu verwalten.
- In der Prognosekonfiguration müssen die Elemente des Prognosenavigationsbereichs in einer benutzerdefinierten App hinzugefügt werden.
Problem 10 – Prognosen für die Benutzerhierarchie können nicht angezeigt werden
Ursache
Dieses Problem tritt aufgrund unzureichender Berechtigungen auf, um die Prognose anzuzeigen.
Lösung
Um das Problem zu beheben, stellen Sie sicher, dass:
Eine dieser Bedingungen ist erfüllt:
Sie sind der Besitzer der Prognose. Das Nachschlagefeld "Besitzer" im Schritt "Berechtigungen " der Prognosekonfiguration zeigt an, wer der Besitzer ist.
Sie sind Teil der Sicherheitsrollen, die über die Leseberechtigung verfügen, wie im Berechtigungsschritt der Prognosekonfiguration konfiguriert.
Jemand hat die Prognose für Sie freigegeben. Weitere Informationen finden Sie unter Prognosefreigabe aktivieren oder deaktivieren.
Das Nachschlagefeld "Besitzer" im Schritt "Berechtigungen " der Prognosekonfiguration ist nicht auf "None" festgelegt. Wenn sie auf "Keine" festgelegt ist, kann niemand die Prognose anzeigen.
Problem 11 – Prognosefeldwerte zeigen im Prognoseraster null oder leer
Ursache
Die Spalten, die dem Feld "Auswahl", "Betrag" und "Datum" zugeordnet sind, haben möglicherweise die Sicherheit auf Feldebene aktiviert.
Lösung
Um das Problem zu lösen, müssen Sie der Benutzer "Dynamics 365 Sales Forecasting" in den Feldsicherheitsprofilen die Berechtigung "Lesen" erteilen. Andernfalls wird in der Spalte 0 für alle Benutzer angezeigt. Führen Sie die folgenden Schritte aus, um die Feldsicherheitsprofile zu konfigurieren:
- Wechseln Sie zu Den>Sicherheitsprofilen für das Sicherheitsfeld "Einstellungen für erweiterte Einstellungen>>".
- Wählen Sie das Feldsicherheitsprofil aus, das dem Feld zugeordnet ist, das 0 anzeigt.
- Wählen Sie "Benutzer>hinzufügen" aus.
- Suchen Sie nach dem Benutzer "#Dynamics 365 Sales Forecasting", aktivieren Sie das Kontrollkästchen mit dem Benutzernamen, und wählen Sie dann "Hinzufügen" aus>.
- Wählen Sie Feldberechtigungen aus, und erteilen Sie dem Feld Leseberechtigungen.
- Speichern und schließen Sie das Profil.
Berechnen Sie die Prognose neu, und stellen Sie sicher, dass in der Spalte geeignete Werte angezeigt werden.
Problem 12 – Die Vorhersagespalte auf der Seite "Prognosen" kann nicht manuell neu berechnet werden.
Ursache
Die Vorhersagespalte auf der Seite "Prognosen" kann nicht manuell neu berechnet werden.
Lösung
Die Vorhersagespalte in der Prognose wird automatisch nach sieben Tagen neu berechnet und unterstützt keine manuelle Neuberechnung. Dies liegt daran, dass Vorhersagen auf KI-gesteuerten Modellen basieren, die historische Daten und die offene Vertriebspipeline betrachten, um das zukünftige Umsatzergebnis vorherzusagen. In der Vorhersagespalte wird der prognostizierte Umsatz für jeden Verkäufer und Manager basierend auf dem Feld "Status " einer Verkaufschance angezeigt. Um die Genauigkeit der Vorhersagen zu optimieren, stellen Sie sicher, dass die Werte der Prognosekategorie mit dem Feld Status synchronisiert sind. Für die Out-of-the-box-Prognosekategorie stellt ein Workflow sicher, dass die Prognosekategorie mit dem richtigen Wert aktualisiert wird, wenn eine Verkaufschance als Gewonnen oder Verloren geschlossen wird.
Problem 13 – Die zugrunde liegende Rasteransicht der Prognose ist deaktiviert (schreibgeschützt), wenn die Seite geladen wird.
Ursache
Ein in der Prognosekonfiguration konfiguriertes benutzerdefiniertes JavaScript verhindert, dass das Raster bearbeitet werden kann.
Lösung
Um das Problem zu beheben, überprüfen Sie den benutzerdefinierten JavaScript-Code, und überprüfen Sie, ob die zugrunde liegende Datensatzrasteransicht deaktiviert wird.