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Dieser Artikel hilft beim Beheben von Fehlern, die auftreten, wenn Sie versuchen, Microsoft Dynamics 365 App für Outlook zu verwenden oder zu öffnen.
Gilt für: Dynamics 365 App für Outlook
Ursprüngliche KB-Nummer: 4563997, 4229661
Symptom 1
Wenn Sie versuchen, Dynamics 365 App für Outlook zu verwenden, wird eine Fehlermeldung angezeigt, die dem folgenden ähnelt:
Sie verfügen nicht über erforderliche Berechtigungen (prvReadOrganization), wodurch bestimmte Funktionen begrenzt werden. Wenden Sie sich an Ihren Administrator, um den erforderlichen Zugriff zu erhalten.
Ursache
Dieser Fehler tritt auf, wenn der benutzer, der dem Postfachdatensatz zugeordnet ist, nicht über ausreichende Berechtigungen verfügt, um Dynamics 365 App für Outlook zu verwenden.
Symptom 2
Wenn Sie Dynamics 365 App für Outlook öffnen, wird die folgende Fehlermeldung angezeigt:
Wir bitten um Entschuldigung.
Wir können Dynamics 365 App für Outlook nicht anzeigen, da die aktuelle Benutzerrolle nicht über erforderliche Berechtigungen verfügt. Wenden Sie sich an Ihren Administrator, damit der Dynamics 365 App for Outlook-Lösung eine erforderliche Sicherheitsrolle zugewiesen ist.
Wenn Sie "Weitere anzeigen" auswählen, enthalten die zusätzlichen Details die folgenden Informationen:
Fehler: Sie verfügen nicht über berechtigungen zum Abrufen der Id "AppforOutlookModule"
Ablaufverfolgung: Fehler: Sie verfügen nicht über die Berechtigung zum Abrufen der Id "AppforOutlookModule" unter "neu" ...
Ursache
Dieser Fehler tritt auf, wenn die Dynamics 365-Sicherheitsrolle keinen Zugriff auf das App-Modul hat, das von der Dynamics 365 App für Outlook verwendet wird.
Lösung
Verwenden Sie eine der folgenden Optionen, um diese Probleme zu lösen.
Option 1: Zuweisen der Sicherheitsrolle "Dynamics 365 App for Outlook User"
Die Dynamics 365-App für Outlook-Benutzersicherheitsrolle kann Benutzern zugewiesen werden, die Dynamics 365 App für Outlook verwenden müssen. Diese Sicherheitsrolle ist ab Build 9.1.0.4206 verfügbar. Diese Option stellt sicher, dass die Benutzer über die grundlegenden Berechtigungen verfügen, die für den Zugriff auf Dynamics 365 App für Outlook erforderlich sind.
Option 2: Zuweisen von Berechtigungen zu einer benutzerdefinierten Sicherheitsrolle
Wenn Sie eine Sicherheitsrolle so anpassen möchten, dass sie die erforderlichen Berechtigungen enthält, lesen Sie den Abschnitt "Weitere Informationen " für eine Liste der Berechtigungen, die für die Verwendung von Dynamics 365 App für Outlook erforderlich sind.
Wichtig
Benutzerdefinierte Sicherheitsrollen haben standardmäßig keinen Zugriff auf das Dynamics 365-App-Modul. Die schritte in Schritt 3: Bereitstellen des Zugriffs auf Sicherheitsrollen sind ebenfalls erforderlich.
Weitere Informationen
In der folgenden Tabelle sind berechtigungen aufgeführt, die für die Verwendung von Dynamics 365 App für Outlook und die Registerkarte in einer Sicherheitsrolle erforderlich sind, in der sich die Berechtigungen befinden.
Ein Benutzer mit der Rolle "Systemadministrator" kann eine Sicherheitsrolle suchen und ändern, indem er zu den Sicherheitsrollen "Einstellungen>">navigiert.
Um anzuzeigen, welche Rollen einem bestimmten Benutzer zugewiesen sind, navigieren Sie zu "Einstellungen", wählen Sie "Sicherheit" aus, wählen Sie "Benutzer" aus, wählen Sie den jeweiligen Benutzerdatensatz und dann "Rollen verwalten" aus.
Rechtename | Entität | Standort (Registerkarte) innerhalb von Sicherheitsrollen |
---|---|---|
prvReadEmailServerProfile | E-Mail-Serverprofil | Unternehmensverwaltung |
prvReadRole | Sicherheitsrolle | Unternehmensverwaltung |
prvReadUser | Benutzer | Unternehmensverwaltung |
prvWriteMailbox | Postfach | Unternehmensverwaltung |
prvReadMailbox | Postfach | Unternehmensverwaltung |
prvReadOrganisation | Organisation | Unternehmensverwaltung |
prvSyncToOutlook (exchangesyncidmapping) | Synchronisierung mit Outlook | Unternehmensführung > Datenschutzbezogene Rechte |
prvUseOfficeApps | Dynamics 365 App for Outlook verwenden | Unternehmensführung > Datenschutzbezogene Rechte |
prvAppendToAccount | Account | Kerndatensätze |
prvReadAccount | Account | Kerndatensätze |
prvDeleteActivity | Aktivität | Kerndatensätze |
prvAppendActivity | Aktivität | Kerndatensätze |
prvWriteActivity | Aktivität | Kerndatensätze |
prvCreateActivity | Aktivität | Kerndatensätze |
prvReadActivity | Aktivität | Kerndatensätze |
prvAppendToActivity | Aktivität | Kerndatensätze |
prvShareActivity | Activity | Kerndatensätze |
prvAppendToContact | Contact | Kerndatensätze |
prvReadKontakt | Kontakt | Kerndatensätze |
prvCreateContact | Kontakt | Kerndatensätze |
prvReadUserQuery | Gespeicherte Sicht | Kerndatensätze |
prvReadAppModule | Modellgesteuerte App | Anpassung |
prvReadAttribute | Feld | Anpassung |
prvReadEntity | Entität | Anpassung |
prvReadRelationship | Beziehung | Anpassung |
prvReadSystemApplicationMetadata | Systemanwendungsmetadaten | Anpassung |
prvReadSystemForm | Systemformular | Anpassung |
prvReadUserApplicationMetadata | Benutzeranwendungsmetadaten | Anpassung |
prvReadQuery | Ansicht | Anpassung |
prvReadWebResource | Webressource | Anpassung |
prvSearchAvailability | Verfügbarkeit suchen | Service-Verwaltung > Verschiedene Rechte |
In der folgenden Tabelle sind zusätzliche Berechtigungen aufgeführt, die erforderlich sind, um einige der Standardansichten anzuzeigen, die in den Dynamics 365 App für Outlook-Formularen verwendet werden. Ohne diese Berechtigungen sieht ein Benutzer möglicherweise den folgenden Fehler anstelle der erwarteten Ansicht (Untergrid) von Datensätzen:
Sie sind nicht berechtigt, auf diese Datensätze zuzugreifen. Wenden Sie sich an Ihren Microsoft Dynamics 365-Administrator, um Hilfe zu bitten.
Rechtename | Entität | Standort (Registerkarte) innerhalb von Sicherheitsrollen |
---|---|---|
prvReadIncident | Case | Dienst |
prvReadOpportunity | Möglichkeit | Kerndatensätze |
prvReadCompetitor | Mitbewerber | Vertrieb |
prvReadConnection | Verbindung | Kerndatensätze |