Die mobile Field Service-App kann aufgrund fehlender Dateien nicht gestartet werden.
Dieser Artikel enthält eine Lösung für ein Problem, bei dem die mobile Dynamics 365 Field Service-App nicht gestartet werden kann.
Problembeschreibung
Wenn Sie mit der Verwendung der neuen Benutzeroberfläche in der mobilen Dynamics 365 Field Service-App beginnen, wird eine Fehlermeldung angezeigt, die besagt, dass bestimmte Dateien fehlen.
Ursache
Einige erforderliche Quelldatensätze fehlen. Diese Datensätze sollten beim Installieren der Field Service-App erstellt werden, aber in seltenen Fällen werden sie nicht erfolgreich erstellt oder beschädigt. Es ist auch möglich, dass ein Benutzer die Datensätze gelöscht hat.
Lösung
Schritt 1: Überprüfen, ob die MobileSource-Tabelle Daten enthält
Wechseln Sie zu Power Apps , und öffnen Sie die Umgebung, die Sie überprüfen möchten.
Wählen Sie "Tabellen" aus, wählen Sie den "Alle"-Filter aus, und suchen Sie nach der
MobileSource
(msdyn_mobilesource
) Tabelle.Wählen Sie die Tabelle aus, und überprüfen Sie, ob sie die folgenden Daten in der Spalte "Name " enthält:
- /card/bookingListViewItem.yml
- /card/defaultViewItem.yml
- /card/serviceTaskGridItem.yml
- /sitemaps/mobile.yml
Wenn keine Daten in der Tabelle vorhanden sind, hat etwas mit dem Lösungsupdate nicht geklappt.
Schritt 2: Wenden Sie das Update der Felddienstlösung erneut an.
Öffnen Sie in Power Apps Ihre Umgebung, und wechseln Sie zu "Lösungen".
fieldservice_anchor
Suchen und löschen Sie dieFieldService_Anchor
Lösung.Wechseln Sie zum Power Platform Admin Center , und wählen Sie die Umgebung aus, in der Sie die Lösung gelöscht haben.
Wählen Sie in den Umgebungsdetails unter "Ressourcen" dynamics 365-Apps aus.
Wählen Sie "App>Dynamics 365 for Field Service>Weiter installieren" aus.
Akzeptieren Sie die Nutzungsbedingungen, und wählen Sie "Installieren" aus.
Überprüfen Sie nach der Installation der Lösung mithilfe von Schritt 1, ob die Tabelle die erforderlichen Daten enthält.