Beheben von Fehlern in Microsoft 365-Aufbewahrungs- und Aufbewahrungsbezeichnungsrichtlinien
Wenn ein Fehler auftritt, der sich auf Die Aufbewahrungs- oder Aufbewahrungsbezeichnungsrichtlinien von Microsoft 365 bezieht, wählen Sie die entsprechende Fehlerbeschreibung aus der folgenden Liste aus:
- Einstellungen nicht gefunden
- Leider hat etwas nicht geklappt
- Der Standort ist mehrdeutig.
- Der Speicherort ist nicht mehr vorhanden.
- Die Website ist gesperrt.
- Ihre Richtlinie wird weiterhin verarbeitet.
- Wir können Ihre Richtlinie nicht verarbeiten.
- Wir konnten diesen Standort nicht finden.
- Es ist ein Problem aufgetreten.
- Sie können hier keinen Halteraum anwenden.
- Ihre Richtlinie bleibt in PendingDeletion hängen
Wenn keine der Lösungen für Ihr Problem zutrifft, wenden Sie sich an Microsoft-Support.
Informationen zum Identifizieren von Aufbewahrungsrichtlinienfehlern finden Sie unter Identifizieren von Fehlern in Microsoft 365-Aufbewahrungs- und Aufbewahrungsbezeichnungsrichtlinien.
Wichtig
Microsoft Purview unterstützt keine Richtlinien, die Fehler enthalten. Sie müssen zunächst alle Richtlinienfehler beheben. Andernfalls funktionieren Aufbewahrungs- und Aufbewahrungsbezeichnungsrichtlinien möglicherweise nicht wie beabsichtigt.
Fehler: Einstellungen nicht gefunden
Symptome
Wenn Sie den Detailbereich für eine Aufbewahrungsrichtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Einstellungen nicht gefunden" angezeigt.
Ursache
Ihre Aufbewahrungsrichtlinie verfügt über keine Aufbewahrungsregeln.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie und dann Bearbeiten aus.
Fügen Sie unter Aufbewahrungseinstellungen Ihrer Aufbewahrungsrichtlinie Regeln hinzu.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Verwenden Sie das entsprechende Cmdlet für Ihre Workload, um Ihrer Aufbewahrungsrichtlinie Regeln hinzuzufügen.
Verwenden Sie das Cmdlet New-RetentionComplianceRule für Richtlinien mit folgenden Zielen:
- Microsoft Exchange Online E-Mail
- Microsoft SharePoint-Websites
- Microsoft OneDrive-Konten
- Microsoft 365-Gruppen
- Microsoft Skype for Business-Unterhaltungen
- Öffentliche Ordner in Exchange Online
- Microsoft Teams-Chatnachrichten
- Teams-Kanalnachrichten
Um beispielsweise eine Regel hinzuzufügen, die einen unbegrenzten Aufbewahrungszeitraum angibt, führen Sie den folgenden Befehl aus:
New-RetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
Verwenden Sie das Cmdlet New-AppRetentionComplianceRule für Richtlinien mit folgenden Zielen:
- Private Teams-Kanalnachrichten
- benutzernachrichten Microsoft Viva Engage
- Viva Engage Communitynachrichten
Um beispielsweise eine Regel hinzuzufügen, die einen unbegrenzten Aufbewahrungszeitraum angibt, führen Sie den folgenden Befehl aus:
New-AppRetentionComplianceRule -Name "<new rule name>" -Policy "<existing policy name>" -RetentionDuration Unlimited
Fehler: Es ist ein Fehler aufgetreten.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Es ist ein Fehler aufgetreten" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen PolicyNotifyError
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
In der Benachrichtigungspipeline des Richtliniensynchronisierungs- und Verteilungsprozesses ist ein nicht angegebener Fehler aufgetreten.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Der Speicherort ist mehrdeutig.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Der Speicherort ist mehrdeutig" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen MultipleInactiveRecipientsError
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Das System hat mehr als ein Ergebnis für den angegebenen Speicherort zurückgegeben. Damit das System eine Richtlinie anwenden kann, muss jeder anwendbare Standort eine Übereinstimmung aufweisen.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie nach zusätzlichen Auflösungsoptionen im Bereich mit den Richtliniendetails, der geöffnet wird, wenn Sie den Richtliniennamen auswählen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie und dann Bearbeiten aus.
Entfernen Sie die doppelten Speicherorte aus der Richtlinie.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Entfernen Sie die doppelten Speicherorte aus der Richtlinie, indem Sie das Cmdlet Set-RetentionCompliancePolicy verwenden. Um beispielsweise einen Exchange-Speicherort zu entfernen, verwenden Sie den
RemoveExchangeLocation
Switch.Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Der Speicherort ist nicht mehr vorhanden.
Symptome
Wenn Sie versuchen, eine Richtlinie im Microsoft Purview-Complianceportal zu erstellen oder zu aktualisieren, schlägt der Vorgang fehl. Im Detailbereich für die Richtlinie wird die Fehlermeldung "Der Speicherort ist nicht mehr gespeichert" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen SiteOutOfQuota
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Der Speicherort verfügt nicht über genügend speicherplatz, damit das System Ihre Richtlinien- oder Richtlinienaktualisierung anwenden kann.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Erhöhen Sie das Speicherkontingent für den angegebenen Speicherort. Wenden Sie sich an den Websiteadministrator oder den globalen SharePoint-Administrator, um das Kontingent für den Standort zu verwalten. Sie können auch unnötige Elemente löschen, um den verfügbaren Speicherplatz zu erhöhen.
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Erhöhen Sie das Speicherkontingent. Wenden Sie sich an den Websiteadministrator oder den globalen SharePoint-Administrator, um das Kontingent für den Standort zu verwalten. Sie können auch unnötige Elemente löschen, um den verfügbaren Speicherplatz zu erhöhen.
Nachdem Sie das Speicherkontingent erhöht haben, stellen Sie eine Verbindung mit Security & Compliance PowerShell her.
Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie zum erneuten Bereitstellen der Richtlinie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Die Website ist gesperrt.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Die Website ist gesperrt" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen SiteInReadOnlyOrNotAccessible
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Ein Administrator hat die Website gesperrt, oder das System hat die Website während eines automatisierten Prozesses vorübergehend gesperrt. Während eines automatisierten Prozesses sind Updates nicht zulässig.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Wenden Sie sich an den Websiteadministrator oder den globalen SharePoint-Administrator, um die Website zu entsperren, und stellen Sie diese Richtlinie dann erneut bereit.
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Wenden Sie sich an den Websiteadministrator oder den globalen SharePoint-Administrator, und stellen Sie diese Richtlinie dann erneut bereit, um die Website zu entsperren.
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Wenn die Website entsperrt ist, wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Ihre Richtlinie wird weiterhin verarbeitet.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Wir verarbeiten Ihre Richtlinie weiterhin" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen PolicySyncTimeout
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Die Richtliniensynchronisierung wurde nicht innerhalb des erwarteten Zeitrahmens abgeschlossen.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Ihre Richtlinie kann nicht verarbeitet werden.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Wir können Ihre Richtlinie nicht verarbeiten" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen ActiveDirectorySyncError
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Die Richtlinie wurde nicht mit Microsoft Entra ID synchronisiert.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Dieser Speicherort konnte nicht gefunden werden.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Dieser Speicherort wurde nicht gefunden" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen FailedToOpenContainer
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Die Richtlinie kann nicht mit einem Speicherort synchronisiert werden, da der Speicherort nicht vorhanden ist. Der Speicherort war möglicherweise bereits vorhanden.
Hinweis
Wenn dieser Fehler auftritt, erfordert das System, dass Sie die problematischen Speicherorte im Rahmen ihrer nächsten Aktualisierung der Richtlinie entfernen.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Entfernen Sie die problematischen Speicherorte aus der Richtlinie.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Entfernen Sie die problematischen Speicherorte mithilfe des Cmdlets Set-RetentionCompliancePolicy aus der Richtlinie. Um beispielsweise einen Exchange-Speicherort zu entfernen, verwenden Sie den
RemoveExchangeLocation
Switch.Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Es ist ein Problem aufgetreten.
Symptome
Wenn Sie den Detailbereich für eine Richtlinie im Microsoft Purview-Complianceportal überprüfen, wird die Fehlermeldung "Es ist ein Problem aufgetreten" angezeigt.
Wenn Sie den folgenden Befehl ausführen, sehen InternalError
Sie in dem Wert, der von der DistributionResults
-Eigenschaft zurückgegeben wird:
Get-RetentionCompliancePolicy -Identity "<policy name>" -DistributionDetail | Select -ExpandProperty DistributionResults
Ursache
Beim Synchronisierungs- und Verteilungsprozess der Richtlinie ist ein nicht angegebener Fehler aufgetreten.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben. Wenn Sie Methode 1 verwenden, suchen Sie im Bereich mit den Richtliniendetails nach zusätzlichen Auflösungsoptionen.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Suchen Sie im Microsoft Purview-Complianceportal auf den folgenden Registerkarten nach der Richtlinie:
- Datenlebenszyklusverwaltung>Microsoft 365>Aufbewahrungsrichtlinien
- Datenlebenszyklusverwaltung>Microsoft 365>Bezeichnungsrichtlinien
- Datensatzverwaltung>Bezeichnungsrichtlinien
Wählen Sie die Richtlinie aus, um den Bereich mit den Richtliniendetails zu öffnen. Stellen Sie sicher, dass Sie den Richtliniennamen und nicht das entsprechende Kontrollkästchen aktivieren. Andernfalls wird der Detailbereich nicht geöffnet.
Wählen Sie im Bereich mit den Richtliniendetails die Option Wiederholen aus. Die Richtlinie wechselt in den Status "Ausstehend", bis die Richtliniensynchronisierung und -verteilung abgeschlossen sind.
Methode 2: Verwenden von PowerShell
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Wiederholen Sie die Synchronisierung und Verteilung der Richtlinie. Verwenden Sie das Cmdlet Set-RetentionCompliancePolicy zusammen mit dem
RetryDistribution
Switch, um die Richtlinie erneut bereitzustellen:Set-RetentionCompliancePolicy -Identity "<policy name>" -RetryDistribution
Fehler: Hier können Sie keinen Halteraum anwenden.
Symptome
Wenn Sie versuchen, einer Richtlinie im Microsoft Purview-Complianceportal einen Speicherort hinzuzufügen, schlägt der Vorgang fehl, und die Fehlermeldung "Hier können Sie keinen Halteraum anwenden" angezeigt wird.
Wenn Sie versuchen, einer Richtlinie mithilfe von PowerShell einen Speicherort hinzuzufügen, wird die RecipientTypeNotAllowed
Fehlermeldung angezeigt.
Ursache
Sie haben versucht, einer Richtlinie einen Postfachspeicherort hinzuzufügen, aber die Richtlinie unterstützt den Postfachtyp nicht. Dieser Fehler tritt nur auf, wenn einer Richtlinie ein Speicherort hinzugefügt wird.
Lösung
Verwenden Sie eine der folgenden Methoden, um dieses Problem zu beheben.
Methode 1: Verwenden des Microsoft Purview-Complianceportal
Zurück zu dem Schritt, in dem Sie die Richtlinienspeicherorte angegeben haben, und entfernen Sie dann die problematischen Speicherorte aus der Richtlinie.
Wiederholen Sie das Update.
Methode 2: Verwenden von PowerShell
Entfernen Sie in dem Skript oder Befehl, das Sie zum Hinzufügen von Speicherorten verwendet haben, die problematischen Speicherorte. Die entsprechenden PowerShell-Cmdlets sind:
Wiederholen Sie das Update.
Fehler: Ihre Richtlinie bleibt in PendingDeletion hängen.
Symptome
Wenn Sie versuchen, eine Richtlinie zu löschen, schlägt der Vorgang fehl.
Ursache
Beim Versuch, die Richtlinie zu löschen, ist ein nicht angegebener Fehler aufgetreten.
Lösung
Herstellen einer Verbindung zur Security & Compliance Center-PowerShell.
Entfernen Sie die Richtlinie. Verwenden Sie das Cmdlet Remove-RetentionCompliancePolicy zusammen mit dem
ForceDeletion
Schalter:Remove-RetentionCompliancePolicy -Identity "<policy name>" -ForceDeletion
Weitere Informationen
Informationen zur Behandlung von eDiscovery-Problemen finden Sie unter Beheben allgemeiner eDiscovery-Probleme.