KB: Error 0000B00F when attempting to delete a server from the Default Server Group in Microsoft Application Virtualization
Here’s a new Knowledge Base article we published today. This one talks about how to fix an issue where you get error 0000B00F attempting to delete a server from the Default Server Group in Microsoft App-V:
=====
Symptoms
When attempting to delete a Server from the Default Server Group in the Microsoft Application Virtualization (App-V) Virtualization Management Console, the following error code is received:
0000B00F
Cause
This occurs because there are licenses assigned to the server that have to be removed before it can be deleted from the Default Server Group. If these licenses have not been automatically removed, it is typically due to the SoftGrid Close Orphaned Sessions Job failing to run or erroring out when it attempted to run. If the App-V database was migrated from another server, it's also possible that the four SoftGrid jobs were not be migrated over along with the database, meaning that these Orphaned Session entries never get cleared from the dbo.LICENSE_ASSIGNMENTS table.
Resolution
Manually run the SoftGrid Close Orphaned Sessions SQL Job to clear out the licenses or manually delete them from the dbo.LICENSE_ASSIGNMENTS table.
First, to determine the server_id of the server that cannot be deleted from the Default Server Group, look at the dbo.SERVERS table which will have the name and hostname fields to identify it (e.g. Server1 has a server_id of 1). Run the following SQL query against the App-V database to determine how many licenses are assigned to Server1:
Select * from License_assignments where server_id = 1
To delete these records directly from the App-V database, run the following SQL query against the App-V database:
Delete from License_assignments where server_id = 1
NOTE Please make a backup of the App-V database prior to running any command or making any modification.
More Information
If the App-V (or SoftGrid) Jobs are not present or not running correctly, eventually the App-V database will grow too large and cause related issues. Please see the following blog posts for more information:
Troubleshooting SoftGrid Database Growth Issues : https://blogs.technet.com/b/appv/archive/2008/08/04/troubleshooting-softgrid-database-growth-issues.aspx
Use the following blog to learn how to create the missing App-V SQL Jobs (Step 7), test and troubleshoot the App-V SQL Jobs (Step 9):
A Complete Guide to SQL 2008 App-V Database Migration : https://blogs.technet.com/b/appv/archive/2012/02/08/a-complete-guide-to-sql-2008-app-v-database-migration.aspx
=====
For the most current version of this article please see the following:
J.C. Hornbeck | System Center & Security Knowledge Engineer
Get the latest System Center news on Facebook and Twitter :
App-V Team blog: https://blogs.technet.com/appv/
ConfigMgr Support Team blog: https://blogs.technet.com/configurationmgr/
DPM Team blog: https://blogs.technet.com/dpm/
MED-V Team blog: https://blogs.technet.com/medv/
Orchestrator Support Team blog: https://blogs.technet.com/b/orchestrator/
Operations Manager Team blog: https://blogs.technet.com/momteam/
SCVMM Team blog: https://blogs.technet.com/scvmm
Server App-V Team blog: https://blogs.technet.com/b/serverappv
Service Manager Team blog: https://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: https://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: https://blogs.technet.com/sus/
The Forefront Server Protection blog: https://blogs.technet.com/b/fss/
The Forefront Endpoint Security blog : https://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : https://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: https://blogs.technet.com/b/isablog/
The Forefront UAG blog: https://blogs.technet.com/b/edgeaccessblog/