當您使用 Active Directory 診斷範本執行Perfmon.exe以在域控制器上產生報告時,報表產生程式可能會停止回應
本文提供修正當您使用 Active Directory 診斷範本執行 Perfmon.exe 以產生報告時,報表產生程式停止響應的問題。
原始 KB 編號: 971714
徵兆
當您使用 Active Directory 診斷範本執行 Perfmon.exe 以在 Windows Server 域控制器上產生報告時,程式可能會停止回應。
原因
之所以發生此問題,是因為執行TraceRpt.exe工具的可靠性和 效能監視器 (Perfmon.exe) 主控台在報表產生程式期間耗用太多記憶體和CPU資源。 如果 Windows Server 忙碌且缺少資源,報表產生程式將會停止回應。
解決方法
若要解決此問題,請將您的檔案複製到具有相同伺服器角色且具有足夠硬體資源的不同計算機。 然後,使用檔案執行TraceRpt.exe。 若要這樣做,請遵循下列步驟:
在 [可靠性和 效能監視器 (Perfmon.exe) 控制台中,按兩下 [資料收集器集合],然後按兩下 [系統]。
以滑鼠右鍵按兩下 [ Active Directory 診斷],然後按兩下 [ 啟動]。 檔案收集程式會在 Windows Server 域控制器上啟動。
在報表狀態變更為產生報告,從收集數據的時間<>**之後,請將檔案複製到第二個 Windows Server 域控制器。
注意
您可以在下列位置找到檔案: %systemdrive%\Perflogs\ADDS\ 日期報表產生執行 \*
“-df” 參數是指定以 Perfmon 產生的特定計數/報告架構檔案Microsoft。 此檔名命名為 report.xsl
找出檔案,然後在第二個 Windows Server 域控制器的命令行上執行下列命令:
tracerpt *.blg *.etl -df *PerfmonSchemaFileName.xsl* -report *your_report.html* -f html **** ****
使用 Windows Internet Explorer 檢視產生的.html檔案。