Sysprep 無法在已註冊 MDM 的 Windows 10 裝置上正確執行
本文提供 Sysprep 在行動裝置管理中註冊的 Windows 10 裝置上無法正確執行時的疑難解答秘訣。
徵兆
您必須在操作系統上執行 系統準備 (Sysprep)工具,例如映像或虛擬機(VM),再複製它。 執行 Sysprep 時,您預期一般化程式會從建立它的原始計算機中移除所有唯一資訊。
不過,數個主要專案不會發生此移除:
MDM 註冊 (例如 Intune) 憑證、標識碼、設定等。
Microsoft Entra join 或 Microsoft Entra 裝置註冊憑證和標識符。
此問題會導致 MDM 發生重大問題,因為多個裝置會獲得相同的標識碼,而且不會從 MDM 伺服器接收必要的設定。
原因
當您執行 Sysprep 將電腦一般化時,每個 Windows 元件都有機會從系統移除資訊,例如登錄機碼、憑證、檔案、資料夾等;如果曾經複製安裝,元件知道的任何專案都會造成問題。
但這並不表示每個元件都會移除資訊。
範例:如果您加入 Windows 10 安裝以Microsoft Entra ID,或在 Intune 中註冊,OS 將會收到系結至特定裝置的多個憑證。 其他註冊和裝置標識碼資訊將會寫入登錄中的各種位置,然後套用原則信息和設定。 因此,sysprep 或一般化程式不會移除該資訊。
解決方案
您必須先使用 Sysprep.exe來一般化系統,才能複製或複製 Windows 安裝(實際複製磁碟驅動器,或使用以 VM 為基礎的快照集或差異磁碟技術)。
當您部署重複或映像化 Windows 安裝時,必須在擷取映射之前使用 Sysprep。 Microsoft不支援使用 Sysprep 以外的 SID 複製工具來設定的電腦。 在擷取和部署映像之前,請先重新密封或一般化 Windows 映射。
例如,當您使用 Sysprep 工具將映像一般化時,Sysprep 會移除所有系統特定資訊並重設電腦。 如果您將 Windows 映射傳輸至不同的電腦,則即使另一部電腦具有相同的硬體組態,也必須搭配 /generalize
選項一起執行 Sysprep 命令。 Sysprep /generalize
命令會從 Windows 安裝中移除唯一資訊,讓您可以在不同的電腦上重複使用該映射。
此外,絕對不要複製已加入 Microsoft Entra ID 的裝置,或註冊到 Intune 等 MDM 服務。 否則,使用該映像的所有裝置都會與用戶看起來相同,而 Intune 將無法在它們都提供相同的裝置標識碼和憑證時加以區分。
當您建立映像時,請遵循一致的可重複程式(例如使用 MDT 或 ConfigMgr OSD),同時使用 VM 並執行可完成整個程式的自動化工作順序。 請勿將它加入 Active Directory 或 Microsoft Entra ID,且不會將映射設定為共同管理的狀態,因為該映像已在 Intune 中註冊。 將映像保留在工作組中、執行自定義專案,並在程序結束時執行 sysprep /generalize
。
若要略過此處說明的許多問題,Microsoft建議您使用 Windows Autopilot 將程式自動化。