針對 Configuration Manager 的 商務用 Microsoft Store 與教育版整合進行疑難解答
本文提供一些您可能與 Configuration Manager 整合 商務用 Microsoft Store 和教育版 (MSfB) 整合的主要疑難解答秘訣和修正程式。
如需搭配 Configuration Manager 使用 商務用 Microsoft Store 和教育版的詳細資訊,請參閱使用 Configuration Manager 管理來自 商務用 Microsoft Store 和教育版的應用程式。
監視器
元件狀態
在 Configuration Manager 控制台中,移至 [監視] 工作區,展開 [系統狀態],然後選取 [元件狀態] 節點。 監視下列元件的狀態:
- SMS_BUSINESS_APP_PROCESS_MANAGER
- SMS_CLOUDCONNECTION
同步處理狀態
在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 [商務用 Microsoft Store] 節點。 檢查 [ 上次同步處理狀態 ] 資料行。
檢視同步處理的應用程式
在 Configuration Manager 控制台中,移至 [ 軟體連結庫 ] 工作區,展開 [應用程式管理],然後選取 [市集應用程式的 授權資訊] 節點。
記錄檔
WSfBSyncWorker.log
此記錄檔位於 Configuration Manager 安裝目錄中的服務連接點底下 \Logs
。 它會記錄與雲端服務通訊的相關信息。 此資訊包括元數據、圖示、套件和授權檔擷取。
若要變更記錄層級,請將 LoggingLevel
登入機碼中的值變更為 0
HKLM\SOFTWARE\Microsoft\SMS\Tracing\SMS_CLOUDCONNECTION
。 如需詳細資訊,請參閱 設定記錄選項。
SMS_CLOUDCONNECTION.log
此記錄檔位於 Configuration Manager 安裝目錄中的服務連接點底下 \Logs
。 如果未啟動 WSfBSyncWorker 服務,或重複啟動和停止,請檢閱此記錄檔中的專案。
注意
此記錄檔與其他功能共用。
BusinessAppProcessWorker.log
此記錄檔位於階層中頂層月臺的月臺伺服器上。 它位於 \Logs
Configuration Manager 安裝目錄中。 它會記錄下列程式的相關信息:
- 將 BusinessAppProcessWorker 元件同步的元數據資訊插入資料庫中
- 在中處理檔案
\InstallDir\inboxes\businessappprocess.box
SMS_BUSINESS_APP_PROCESS_MANAGER.log
此記錄檔位於階層中頂層月臺的月臺伺服器上。 它位於 \Logs
Configuration Manager 安裝目錄中。 如果未啟動 BusinessAppProcessWorker 服務,或重複啟動和停止,請檢閱此記錄檔中的專案。
上次同步失敗
當上次同步狀態 失敗時,請先檢閱下列 記錄檔 來識別徵兆:
- WSfbSyncWorker.log
- SMS_CLOUDCONNECTION.log
然後查看下列其中一節的常見問題:
- 授權錯誤
- 秘密金鑰無效
- 取得應用程式令牌時發生錯誤
- 內容位置不存在或許可權不正確
- 發出 HTTP 要求呼叫 'GET' 方法時發生錯誤
- 無法將更多位元組寫入緩衝區
- 在線應用程式下載失敗,0x8024500c
授權錯誤
原因
如果已設定的 Microsoft Entra 應用程式沒有管理此租使用者 商務用 Microsoft Store 和教育的許可權,就可能發生此問題。
因應措施
- 以系統管理員身分登入 商務用 Microsoft Store 或教育版入口網站。
- 移至 [ 設定],然後選取 [管理工具]。
- 如果未列出應用程式,請選取 [新增管理工具]。 然後依名稱搜尋,然後選取與 Configuration Manager 相同 ClientID 相關聯的Microsoft Entra 應用程式。
- 如果狀態未顯示 [作用中],請在 [動作] 區段中選取 [啟用]。
- 在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 [商務用 Microsoft Store] 節點。 與存放區同步處理,或等候下一個同步間隔發生。
提示
若要在 Configuration Manager 中尋找 ClientID:
- 在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 [Microsoft Entra Tennts] 節點。
- 選取您用於 商務用 Microsoft Store和教育整合的租使用者。
- 在結果窗格中,尋找相符的應用程式,並查看 [用戶端標識符 ] 資料行。
秘密金鑰無效
原因
如果Microsoft Entra 應用程式上 商務用 Microsoft Store 和教育版設定的秘密密鑰已過期,就可能發生此問題。
解決方法
更新 Microsoft Entra 應用程式的秘密金鑰。 如需詳細資訊,請參閱 更新秘密密鑰。
取得應用程式令牌時發生錯誤
原因
如果已連線的應用程式已不存在於 Microsoft Entra 識別碼中,就可能發生此問題。
解決方法
刪除並重新建立與 商務用 Microsoft Store和教育版的連線。
- 在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 [商務用 Microsoft Store] 節點。
- 選取現有的連線。
- 選取功能區中的 [ 刪除 ]。
然後重新建立連線。 如需詳細資訊,請參閱下列文章:
內容位置不存在或許可權不正確
原因
當您設定 商務用 Microsoft Store 和教育版連線時,您會指定用於儲存同步處理內容的網路共用。 如果此共用不存在或許可權不正確,就可能發生此問題。 服務連接點的電腦帳戶應該是此目錄和任何子目錄的擁有者。 如果不是,您會看到類似下列錯誤的錯誤:
Failed to download package d788cc1b-ab00-bb5f-1548-f2dfe717583b-X86-Arm for product 9WZDNCRFJ3PS\0015.
System.IO.IOException: This security ID may not be assigned as the owner of this object.
若要檢視您設定的位置:
在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 [商務用 Microsoft Store] 節點。
選取帳戶並開啟其 [屬性]。
切換至 [設定] 索引標籤。[位置] 設定會顯示從 商務用 Microsoft Store 和教育版下載的應用程式內容儲存網路路徑。
因應措施
如果尚未存在,請建立共用。
檢查資料夾的NTFS許可權,以及網路共用的許可權。 授與服務連接點 的電腦帳戶讀取 和 寫入 許可權。
如果您想要重新設定位置,請刪除並重新建立與新內容位置的連線。
發出 HTTP 要求呼叫 'GET' 方法時發生錯誤
原因
如果從存放區同步處理應用程式的時間太長,內容URL過期,就可能發生此問題。
因應措施
重試同步處理程式
- 在 Configuration Manager 控制台中,移至 [系統管理] 工作區,展開 [雲端服務],然後選取 商務用 Microsoft Store 節點。
- 選取連接。 在功能區中,選取 [從 商務用 Microsoft Store 同步]。
每次時,它都應該繼續進一步。 視下列因素而定,可能需要數次重試:
- 離線應用程式的數目
- 封裝的大小
- 網路速度
每次嘗試時,您應該會看到錯誤次數較少。 如果錯誤數目未減少,則會出現另一個問題。
無法將更多位元組寫入緩衝區
原因
如果應用程式的套件大於 500 MB,就可能發生此問題。 Configuration Manager 僅支援使用小於 500 MB 的封裝自動同步處理離線應用程式。
因應措施
您無法自動同步處理這些應用程式,但您可以下載內容,並手動建立應用程式:
從下列程式代碼列取得 失敗的應用程式識別碼,WSfbSynWorker.log:
Error(s) syncing or downloading application <ApplicationID> from the Microsoft Store for Business.
以系統管理員身分登入 商務用 Microsoft Store 或教育版入口網站。 尋找此應用程式的頁面。
提示
頁面的網址類似於:
https://businessstore.microsoft.com/en-us/store/p/app/ApplicationID
如果尚未選取,請 選取 [脫機]。 然後選取 [ 管理]。
針對所有支持的平臺,在您的應用程式內容共用上建立個別的資料夾。
將套件下載至套件資料夾。
將編碼的授權檔案下載為
.bin
套件資料夾的檔案。將所有必要的架構下載至套件資料夾。
在 Configuration Manager 控制台中,移至 [ 軟體連結庫 ] 工作區,展開 [應用程式管理],然後選取 [ 應用程式 ] 節點。
建立應用程式,手動指定應用程式資訊。
針對您先前下載的每個支援平臺建立部署類型。
類型: Windows 應用程式套件 (*.appx,*.appxbundle)
指定實際應用程式套件的 appx/appxbundle,而不是必要的相依性套件。
在最終 匯入資訊頁面上確認下列詳細數據 :
- 許可證檔: 指定檔案
.bin
。 離線應用程式需要此授權檔。 - Windows 應用程式相依性: 確認已為此套件下載所有必要的相依性。
在線應用程式下載失敗,0x8024500c
原因
下載期間發生0x8024500c錯誤,通常是因為 「不要連線到任何封鎖 Windows Update 存取的 Windows Update 因特網位置 」組策略所造成。
因應措施
請勿啟用 [不要連線到任何 Windows Update 因特網位置 ] 組策略物件。
同步不會執行
本節涵蓋下列同步問題:
- 您手動啟動同步處理程式,但不會執行
- 網站不會每天自動同步
從檢閱下列 記錄檔 來識別徵兆開始:
- BusinessAppProcessWorker.log
- SMS_BUSINESS_APP_PROCESS_MANAGER.log
- WsfbSyncWorker.log
- SMS_CLOUDCONNECTION.log
然後查看下列其中一節的常見問題:
手動同步未啟動
原因
如果您在上一次同步處理后不到 10 分鐘啟動同步處理,就會發生此問題。您無法每隔 10 分鐘同步處理一次。
解決方法
開始另一個同步處理之前,請等候至少 10 分鐘。
自動每日同步處理不會在 SMS_BUSINESS_APP_PROCESS_MANAGER.log 中執行並「關閉 #背景工作角色」錯誤
原因
如果SMS_BUSINESS_APP_PROCESS_MANAGER元件停止 WsfbSyncWorker 線程,就可能發生此問題。 錯誤可能會指定 或 2
4
背景工作角色。
因應措施
重新啟動SMS_EXECUTIVE服務。
如果您無法重新啟動該主要服務,請停止具有 MSfB 背景工作角色的兩個元件,然後啟動這兩個元件:
在執行服務連接點的伺服器上開啟 Windows 登錄
請前往
HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_EXECUTIVE\Threads\SMS_CLOUDCONNECTION
將要求的作業設定為 停止。
重新整理以確認目前狀態 = 已停止。
請前往
HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_EXECUTIVE\Threads\SMS_BUSINESS_APP_PROCESS_MANAGER
將要求的作業設定為 停止。
重新整理以確認目前狀態 = 已停止。
在 SMS_CLOUDCONNECTION中,將 [要求作業] 設定為 [ 啟動]。
在 SMS_BUSINESS_APP_PROCESS_MANAGER 中,將 [要求作業] 設定為 [ 啟動]。
語言相關問題
本節包含下列常見問題:
未套用語言選取變更
原因
如果快取語言選取範圍,而且在屬性值變更之後不會清除,就會發生此問題。
因應措施
若要解決此問題,請重新啟動 SMS_Executive 服務。
並非所有選取的語言都存在所有授權資訊
原因
如果 商務用 Microsoft Store和教育版應用程式的授權資訊未包含指定語言的當地語系化數據,就可能發生此問題。
因應措施
手動為已建立的應用程式新增任何遺漏的語言。
離線應用程式
本節包含下列常見問題:
無法建立離線應用程式,因為無法驗證內容
原因
如果離線應用程式的同步處理內容已損毀或修改,就可能發生此問題。
因應措施
啟動新的同步處理。同步處理完成時,它應該驗證並下載任何不正確的內容檔案。
無法安裝從離線授權資訊建立的應用程式
原因
如果您將應用程式部署到執行 1511 版舊版 Windows 10 的用戶端,就可能發生此問題。 只有 Windows 10 1511 版和更新版本才支援來自 商務用 Microsoft Store 和教育版的離線授權應用程式。
解決方法
安裝最新版本的 Windows 10。
下一步
若要尋找其他說明,請參閱 尋找使用 Configuration Manager 的說明。