OpenID 驗證AADSTS50011錯誤:要求中指定的重新導向 URI 不符合
本文說明當您嘗試使用 OpenID Connect (OIDC) 型 Microsoft驗證與 entra ID 使用 OpenID Connect (OIDC) 型驗證的應用程式時,傳回錯誤訊息的問題 AADSTS50011
。
徵兆
當您嘗試使用 OIDC 或 OAuth2 驗證通訊協定搭配 Microsoft Entra 識別碼的應用程式登入時,會收到下列錯誤訊息:
錯誤AADSTS50011 - 要求中指定的重新導向 URI <重新導向 URI> 不符合為應用程式 <AppGUID> 設定的重新導向 URI。 請確定在要求中傳送的重新導向 URI 符合 Azure 入口網站中新增至應用程式的重新導向 URI。 導覽至 https://aka.ms/redirectUriMismatchError 以深入瞭解如何修正此問題。
原因
如果應用程式 (程序代碼) 中設定的重新導向 URI (回復 URL) 和 Microsoft Entra 應用程式註冊不相符,就會發生此錯誤。
當使用者存取應用程式以進行驗證時,應用程式會將使用者重新導向至具有預先定義重新導向 URI 的 entra 識別碼Microsoft。 成功授權用戶之後,Microsoft Entra ID 會驗證下列值:
- 從應用程式傳送的重新導向 URI
- Microsoft Entra ID 中已註冊應用程式中的重新導向 URI 值
如果應用程式傳送的重新導向 URI 不符合 Microsoft Entra 識別碼中的任何重新導向 URI,則會傳回錯誤AADSTS50011。 如果值相符,Microsoft Entra ID 會將用戶傳送至重新導向 URI。
解決方法
若要修正此問題,請遵循下列步驟,在 entra 應用程式註冊Microsoft新增重新導向 URI。
從錯誤訊息複製應用程式識別碼。 這是已在 entra ID Microsoft 中註冊的應用程式識別碼。
前往 Azure 入口網站。 請務必使用有權更新 Microsoft Entra Application 註冊的帳戶登入入口網站。
流覽至 [Microsoft項目標識符]、選取 [應用程式註冊]、使用應用程式標識碼尋找應用程式註冊,然後開啟應用程式註冊頁面。
您也可以使用下列連結直接開啟頁面:
- 如果此應用程式是由組織所擁有(Microsoft Entra 租使用者),請使用
https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>
。 - 如果此應用程式是由您的個人 Microsoft (MSA) 帳戶所擁有,請使用
https://portal.azure.com/#blade/Microsoft_AAD_RegisteredApps/ApplicationMenuBlade/Authentication/appId/<AppGUID>/isMSAApp/true
。
- 如果此應用程式是由組織所擁有(Microsoft Entra 租使用者),請使用
在應用程式註冊頁面上,選取 [ 驗證]。 在 [ 平台組態 ] 區段中,選取 [新增 URI ],將錯誤訊息中顯示的重新導向 URI 新增至 entra ID Microsoft。
儲存變更並等候三到五分鐘,變更才會生效,然後再次傳送登入要求。 您現在應該能夠登入應用程式。 如果您沒有看到 Microsoft Entra 登入頁面,請嘗試從瀏覽器清除密碼快取或使用 InPrivate 瀏覽。
注意
如果從應用程式傳送的重新導向 URI 不是所需的重新導向 URI,您應該更新應用程式程式代碼或設定。
下列影片示範如何修正Microsoft Entra ID 中的重新導向 URI 不符錯誤:
其他相關資訊
如需 Active Directory 驗證和授權錯誤碼的完整清單,請參閱 Microsoft Entra 驗證和授權錯誤碼。
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