共用方式為


優化要求無法修改某些預約

本文可協助系統管理員針對 Microsoft Dynamics 365 Field Service 的資源 排程優化載入 巨集中的優化要求進行疑難解答。

徵兆

優化要求失敗,並出現「系統無法修改某些預約」錯誤訊息。

原因

在下列案例中,優化要求可能會失敗:

  • 使用者會在資源排程優化執行期間手動更新預約。 資源排程優化不會覆寫變更。
  • 工作流程或外掛程式會在資源排程優化執行期間更新相同的預約。 資源排程優化不會覆寫其他系統邏輯所做的變更。
  • 多個資源排程優化排程會共用相同的資源,並同時執行。 如果排程包含重疊的資源、需求和預約,則會取消稍後的排程,且狀態為已封鎖。

解決方法

如需分析和疑難解答,請檢查下列選項:

  • 檢閱優化要求預約方格,並檢查每個需求和預約的 [作業詳細數據 ] 數據行。
  • 檢查共用相同資源、需求和預約的多個排程是否同時執行。 如果是這種情況, 請更新排程以循序 執行,或重新設定排程以避免重疊。 如需詳細資訊,請參閱 解決資源排程優化中的預約衝突。
  • 檢查任何其他使用者或工作流程是否嘗試在優化要求執行期間更新預約。