無法刪除由已啟用 SLA 的實體所組成的受控解決方案
本文提供無法刪除 Dynamics 365 Customer Service 中已啟用服務等級協定 (SLA) 實體的受控解決方案的問題解決方案。
徵兆
您無法刪除包含已啟用 SLA 之實體的受控解決方案。 此實體已建立成先前匯入之解決方案的一部分。
原因
在實體上啟用之後,就無法停用 SLA。
使用此範例來了解問題:
- 在 Org1 中建立新解決方案,並將其命名為現場解決方案。
- 在現場解決方案中建立新實體,並將其命名為現場工作。
- 將現場解決方案匯出為受管理的解決方案。
- 將現場解決方案匯入至新的組織,名稱為 Org2。
下一步:
- 在 Org1 中建立另一個解決方案,並將其命名為差異現場解決方案。
- 將現場工作實體與差異現場解決方案建立關聯。 在實體上啟用 SLA。
- 將差異現場解決方案匯出為受管理的解決方案。
- 將差異現場解決方案匯入至 Org2。
現在,如果您嘗試從 Org2 刪除 Delta Field 解決方案 ,則無法刪除它,因為它有 與已啟用 SLA 的 Field 工作實體相關聯的欄位工作 實體。
解決方法
若要刪除包含已啟用 SLA 之實體的受管理的解決方案,您必須先刪除先前所匯入已建立實體項目的受管理的解決方案。 此動作可確保實體專案已刪除。 然後,您可以再次建立實體,或重新匯入受管理的解決方案。
若要刪除 Org2 中的 Delta Field 解決方案,請先刪除欄位解決方案。
欄位解決方案 可以刪除,因為與其相關聯的實體 — 欄位工作 — 未啟用 SLA。 刪除 欄位解決方案 可確保刪除 SLA 組態和實體。
注意
此因應措施不適用於現成可用的實體,因為您無法刪除現成可用的實體或具有與其相關聯之現成實體的受控解決方案。