Business Central 雲端移轉中的「無法連線到 SQL 資料庫,ErrorCode=SqlFailedToConnect」錯誤
本文將解決當您嘗試連線到 Business Central 雲端移轉中 SQL 資料庫時所發生的「無法連線到 SQL 資料庫 ErrorCode=SqlFailedToConnect」錯誤訊息。
徵兆
當您嘗試連線到 Business Central 雲端移轉中的 SQL 資料庫時,您會收到下列錯誤訊息:
無法連線到 SQL 資料庫 ErrorCode=SqlFailedToConnect。
此錯誤訊息通常會與下列錯誤訊息一起發生:
檢查鏈接的服務組態是否正確,並確定 SQL 資料庫 防火牆允許整合運行時間存取。
原因
錯誤訊息可能有數個原因。 最常見的原因是在長錯誤訊息內部傳回,例如:
使用者帳戶的問題:
使用者登入失敗...
必須變更帳戶的密碼。
帳戶已停用。
SQL Server 未執行,或停用對 SQL Server 的遠端存取:
找不到或無法存取伺服器。 檢查執行個體名稱是否正確以及 SQL Server 執行個體是否設定為允許遠端連接。
解決方法
若要解決此問題,請在 Integration Runtime 主機上執行下列 Windows PowerShell 命令。 如果 Integration Runtime 主機無法連線,則會傳回描述性錯誤。
sqlcmd –S "{SQL Server Name}" -d "{Database Name}" -U "{SQL Server Authenticated User Name}" -P "{PlaceholderSQLServerAuthenticatedPassword}" -Q 'select * from [dbo].[Intelligent Cloud]'
若要允許 Integration Runtime 用戶端 IP 位址存取 SQL Server,請在內部部署 master 資料庫上執行下列命令:
sp_set_firewall_rule
若要允許遠端存取 SQL Server,請執行下列命令:
run sp_configure 'remote access', 1;