Business Central 雲端移轉中的活動逾時
本文提供商務中心雲端移轉期間活動逾時的問題疑難解答步驟。
徵兆
在 Business Central 雲端移轉期間的活動逾時。
原因
如果活動在雲端移轉設定期間逾時,可能是因為 Integration Runtime 無法建立與 SQL Server 的連線,或是因為大型內部部署資料庫中的索引重組而發生。 如果在移轉執行期間逾時,原因很可能是弱式或忙碌的內部部署 SQL Server。
解決方法
如果 SQL 連線永久中斷,請檢查 .NET 4.72 或更新版本是否在整合運行時間的主機上執行。
檢查 Azure Data Factory 頁面上的其他整合運行時間需求。
針對資料庫效能問題,建議您先更新統計數據並重新組織內部部署資料庫中的索引,再設定雲端移轉。
若要更新統計數據,請執行下列查詢(例如,在聯機至內部部署資料庫的 SQL Management Studio Microsoft中):
EXEC sp_updatestats;
若要重新組織索引,請執行下列查詢:
EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'