即使已啟用Microsoft 365 存取,仍會發生許可權錯誤
本文說明如何在嘗試從 Microsoft Teams 存取 Business Central 記錄時,解決與許可權相關的問題,即使使用 Microsoft 365 授權的存取已在 Business Central 系統管理中心正確啟用。
徵兆
當使用者在 Microsoft Teams 交談中選取 Business Central 記錄的連結或卡片時,他們會收到類似「抱歉,目前的許可權會防止動作」的錯誤訊息。
原因
這是依照設計的行為。 系統管理員必須先設定哪些數據可以在 Microsoft Teams 中存取。 如果系統管理員在 Business Central 系統管理中心啟用存取權,但未在 [授權設定] 頁面上指派許可權,則嘗試存取 Microsoft Teams 中的 Business Central 記錄的使用者,將在其用戶記錄布建,而不需要任何物件的許可權。
解決方案
注意
若要解決此問題,您需要 Business Central 中的租用戶系統管理員許可權。
除了在 Dynamics 365 Business Central 系統管理中心啟用 Microsoft 365 存取之外,也會在 [授權設定] 頁面上指派許可權。 不過,在 [授權設定] 頁面上指派的許可權只會套用至新建立的使用者。 對於已建立的使用者,您也必須透過 [使用者清單 ] 頁面指派遺漏的許可權。