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用戶端 IP 位址無法存取 API 伺服器

本文說明如何修正您無法連線到 Azure Kubernetes Service (AKS) 叢集時所發生的問題,因為您的用戶端 IP 位址無法存取 AKS API 伺服器。

必要條件

徵兆

當您嘗試從 Azure 入口網站 存取 Kubernetes 資源,例如 mamespaces 和工作負載時,可能會遇到下列錯誤:

網路錯誤

無法連線到 API 伺服器 'https://< API-server-FQDN>' 或 API 伺服器太忙碌而無法回應。 請檢查您的網路設定並重新整理,然後再試一次。

AKS 資源中 Mamespaces 的螢幕快照。

原因

API 伺服器授權的IP範圍 可能已在叢集的 API 伺服器上啟用,但用戶端的IP位址並未包含在IP範圍中。 若要檢查此功能是否已啟用,請參閱 Azure CLI 中的下列 az aks show 命令是否會產生 IP 範圍清單:

az aks show --resource-group <cluster-resource-group> \
    --name <cluster-name> \
    --query apiServerAccessProfile.authorizedIpRanges

解決方案

查看叢集的 API 伺服器授權範圍,並在該範圍內新增用戶端的 IP 位址。

注意

  1. 您是否從透過 Proxy 伺服器或防火牆路由傳送流量的公司網路存取 API 伺服器? 然後在將用戶端 IP 位址新增至 API 伺服器的授權範圍清單之前,先詢問您的網路管理員。

  2. 此外,在您新增用戶端 IP 位址之前,請先詢問叢集管理員,因為將暫時 IP 位址新增至授權範圍清單時,可能會有安全性考慮。

  1. 從 Azure 入口網站 流覽至叢集。

  2. 在左側功能表中,找出 [設定],然後選取 [網络]。

  3. 在 [ 網络] 頁面上,選取 [ 概觀] 索引標籤。

  4. 選取 [資源設定] 底下的 [管理]。

  5. 在 [ 授權的IP範圍 ] 窗格中,新增您的用戶端IP位址,如下列螢幕快照所示:

    Authorized-ip-ranges 窗格的螢幕快照。

與我們連絡,以取得說明

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