無法連線到 API 伺服器 'https://< API-server-FQDN>' 或 API 伺服器太忙碌而無法回應。 請檢查您的網路設定並重新整理,然後再試一次。
當您嘗試使用 Azure CLI 連線到叢集時,您可能會看到下列錯誤:
"Unhandled Error" err="couldn't get current server API group list: Get \"https://<API-SERVER-FQDN>:443/api?timeout=32s\": dial tcp <API-SERVER-IP>:443: i/o timeout"
Unable to connect to the server: dial tcp <API-SERVER-IP>:443: i/o timeout
Unable to connect to the server: dial tcp <API-SERVER-IP>:443: connectex: A connection attempt failed because the connected party did not properly respond after a period, or established connection failed because connected host has failed to respond.
原因
API 伺服器授權的IP範圍 可能已在叢集的 API 伺服器上啟用,但用戶端的IP位址並未包含在IP範圍中。 若要檢查此功能是否已啟用,請參閱 Azure CLI 中的下列 az aks show 命令是否會產生 IP 範圍清單:
az aks show --resource-group <cluster-resource-group> \
--name <cluster-name> \
--query apiServerAccessProfile.authorizedIpRanges
解決方案
查看叢集的 API 伺服器授權範圍,並在該範圍內新增用戶端的 IP 位址。
注意
您是否從透過 Proxy 伺服器或防火牆路由傳送流量的公司網路存取 API 伺服器? 然後在將用戶端 IP 位址新增至 API 伺服器的授權範圍清單之前,先詢問您的網路管理員。
此外,在您新增用戶端 IP 位址之前,請先詢問叢集管理員,因為將暫時 IP 位址新增至授權範圍清單時,可能會有安全性考慮。