目錄同步處理至 Microsoft Entra 識別元停止,或您警告同步處理一天未註冊超過一天
本文說明 Azure Active Directory 同步工具中的效能問題。 此工具會停止同步處理,或報告同步未在24小時內執行。
原始產品版本:Microsoft Entra ID、Microsoft Intune、Azure 備份、Office 365 身分識別管理
原始 KB 編號: 2882421
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徵兆
您遇到下列其中一個徵兆:
- Microsoft Azure Active Directory 同步作業工具 會停止同步處理。
- 您會收到電子郵件訊息,指出Microsoft Entra ID 在過去 24 小時內未註冊同步處理嘗試。
- 在工具中
MIISClient.exe
,您會收到「已停止伺服器關閉」訊息或「Stopped-Extension-DLL-Exception」訊息。 - 您無法啟動一或多個目錄同步處理服務。
注意
根據預設,目錄同步處理會每三個小時執行一次。
原因
如果有下列一或多個條件成立,即可能發生此問題:
在組態精靈中用來設定目錄同步處理的工作或學校帳戶有下列其中一個問題:
- 帳戶已刪除。
- 帳戶已停用。
- 帳戶密碼已過期。
一或多個目錄同步處理服務的登入帳戶有下列其中一個問題:
- 帳戶已刪除。
- 帳戶已停用。
- 帳戶密碼已過期。
注意
目錄同步處理服務的登入帳戶會自動設定,不應修改。
用於目錄同步處理的系統管理員帳戶已變更。
您有網路連線問題。
目錄同步處理服務已停止。
解決方法
方法 1:手動確認服務已啟動,而且系統管理帳戶可以登入
選取 [開始],選取 [執行],輸入 Services.msc,然後選取 [確定]。
找出 Microsoft Entra Synchronization appliance 服務,然後檢查服務是否已啟動。 如果服務未啟動,請以滑鼠右鍵按兩下服務,然後選取 [ 啟動]。
- 如果您使用 Azure Active Directory 同步工具,請尋找 Azure Active Directory 同步服務。
- 如果您使用 Microsoft Entra Connect,請尋找Microsoft Azure AD 同步。
確認用於目錄同步處理的系統管理員帳戶仍然存在。 並確認帳戶允許登入。 如果帳戶仍然存在,請重設密碼,然後確認您可以登入。 如果系統提示您,請變更密碼。
如果您不知道用來設定目錄同步處理的全域系統管理員帳戶,請遵循您在安裝目錄同步處理裝置的伺服器上執行下列步驟:
移至
%ProgramFiles%\Microsoft Azure AD Sync\UIShell\
,然後執行Miisclient.exe。注意
如果您使用 Microsoft Entra Connect 或 Azure Active Directory 同步服務,請選取 [啟動],然後搜尋並開啟 同步處理服務。
選取 [連接器],然後按兩下 Microsoft Entra 連接器。
選取 [連線能力]。
記下 UserName 值。 這是用來設定目錄同步處理的全域系統管理員帳戶。
在目錄同步處理伺服器上,執行 Microsoft Entra Synchronization appliance 設定精靈。 輸入用於目錄同步處理之系統管理員帳戶的新密碼,然後遵循精靈中的其餘步驟。
出現提示時,請選取 [ 強制目錄同步處理 ] 複選框。
方法 2:解決目錄同步處理服務的登入賬戶問題
選取 [開始],選取 [執行],輸入 Services.msc,然後選取 [確定]。
找出 Microsoft Entra Synchronization appliance 服務:
- 如果您使用 Azure Active Directory 同步工具,請尋找 Azure Active Directory 同步服務。
- 如果您使用 Microsoft Entra Connect,請尋找Microsoft Azure AD 同步。以滑鼠右鍵按兩下服務,然後選取 [屬性]。 在 [ 登入] 索引標籤上,記下列出的帳戶名稱。
注意
不支援將任何目錄同步處理服務設定為以本機系統帳戶登入,而且可能會造成問題。
在已安裝管理工具的域控制器或計算機上,開啟 Active Directory 使用者和電腦 (Dsa.msc),以滑鼠右鍵按兩下功能變數名稱,然後選取 [尋找]。 輸入您在步驟 2 記下的帳戶名稱,然後選取 [ 立即尋找]。
- 如果您找到帳戶,請移至步驟 4。
- 如果您找不到帳戶,可能已刪除該帳戶。 如需如何還原此帳戶的詳細資訊,請參閱 Active Directory 回收站逐步指南。 如果您無法還原帳戶,您必須卸載再重新安裝目錄同步處理用戶端。
以滑鼠右鍵單擊帳戶,然後選取 [ 屬性]。 在 [ 帳戶] 索引標籤的 [帳戶 選項] 底下 , 遵循下列步驟:
- 請確定已選取 [ 密碼永不過期] 複選框。
- 請確定 已清除 [帳戶已 停用] 複選框。 然後,採取下列其中一個動作:
- 如果已選取 [ 帳戶] 複選框,請清除它以啟用帳戶。 然後,重新啟動 Microsoft Entra Synchronization appliance 服務。 若要這樣做,請選取 [ 開始]、選取 [執行]、輸入 Services.msc,然後選取 [ 確定]。 找出服務,以滑鼠右鍵按兩下服務,然後選取 [ 重新啟動]。
- 如果您使用 Azure Active Directory 同步工具,請尋找 Azure Active Directory 同步服務。
- 如果您使用 Microsoft Entra Connect,請尋找Microsoft Azure AD 同步。
- 如果 [帳戶已停用] 複選框已清除,請移至步驟 5。
如果已清除 [ 帳戶] 複選框,有可能手動變更帳戶的密碼。 若要設定新的密碼,請開啟 [Active Directory 使用者和電腦],然後以滑鼠右鍵按兩下帳戶,然後選取 [重設密碼] 以重設密碼。 請注意您設定的密碼,因為您必須在下一個步驟中使用密碼。
在目錄同步處理服務的登入帳號上設定密碼:
選取 [開始],選取 [執行],輸入 Services.msc,然後選取 [確定]。
根據您使用的客戶端,設定下列服務的密碼。 若要這樣做,請以滑鼠右鍵按兩下適當的服務,選取 [屬性],選取 [登入] 索引標籤,然後輸入密碼。
Microsoft Entra Synchronization 用戶端 Microsoft Entra Connect
Forefront Identity Manager 同步處理服務
SQL Server (MOSONLINE) (如果有的話)
Azure Active Directory 同步服務
Azure AD Sync啟動您設定新密碼的服務或服務。
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