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SharePoint Online 和 OneDrive 中的「拒絕存取」或「您需要權限」錯誤

徵兆

當您嘗試使用 SharePoint Online 或商務用 OneDrive 時,可能會收到下列其中一種錯誤訊息:

  • 拒絕存取
  • 您需要存取此網站的權限
  • 在目錄中找不到使用者

當使用者嘗試從 SharePoint Online 或 OneDrive 網站存取其他使用者共用之檔案或資料夾的連結時,會收到下列錯誤訊息:

您無法使用此連結。
很抱歉,您目前以 身分登入,但該帳戶不在此受保護的人員清單中。 若要嘗試其他電子郵件,請登出並再次開啟連結。

原因

這些錯誤可能會因為各種原因而發生,例如:

  • 受影響使用者的權限未正確設定。
  • 用來存取共用連結的帳戶與傳送邀請的帳戶不同。
  • 網站使用者識別碼不符。 如果使用者帳戶從 Microsoft 365 系統管理中心中刪除,然後以使用者主體名稱建立新帳戶, (已刪除帳戶所使用的 UPN) ,則通常會發生識別碼不符的情況。 即使 UPN 相同,也會為新帳戶指派新的識別碼值。 如果使用者已登入 SharePoint,且稍後移至不同的 OU,則 Active Directory 組織單位 (OU) 與 SharePoint 之間的目錄同步處理期間也可能發生不符的情況。

解決方案選項 1:執行檢查使用者存取診斷

注意

此診斷不適用於 GCC High 或 DoD 環境,或不適用於由世紀互聯提供的 Microsoft 365。

Microsoft 365 系統管理員可以在租用戶內執行診斷,以找出可能影響使用者存取的問題。

選取以下執行測試按鈕,這會在 Microsoft 365 系統管理中心填入診斷。

診斷會對嘗試存取 SharePoint 和 OneDrive 網站的內部和訪客使用者執行大量驗證。

解決方案選項 2:手動修正

若要手動修正存取問題,請遵循相關案例的步驟。

使用者無法存取 SharePoint 網站或其他使用者的 OneDrive 網站

  1. 決定使用者應在網站上擁有的權限層級

  2. 使用 [檢查權限] 功能來驗證權限:

    1. 針對 SharePoint 網站,選取 [設定>網站許可權]。 針對 OneDrive 網站,選取 [設定>網站設定>網站許可權]。
    2. 在功能區中,選取 [檢查權限]
    3. 在 [使用者/群組] 欄位中,輸入使用者的名稱,然後選取 [立即檢查]
    4. 請複查使用者在網站上擁有的權限,同時檢查相關安全性群組 (如果適用)。
  3. 若使用者沒有適當的權限,請將檔案網站的權限授與使用者。

  4. 如果使用者繼續收到錯誤訊息,請從網站中移除使用者。 然後重新授予使用者檔案或網站的權限。

    請注意:如果訪客帳戶仍受影響,建議您從 Microsoft 365 系統管理中心中完全移除訪客帳戶。 請確定 使用者已從網站集合中移除。 然後重新授予使用者檔案或網站的權限。

使用者無法存取自己的 OneDrive 網站

此問題通常是因為網站使用者識別碼不符所造成。

若要修正此問題,請檢查是否有新的 UPN 存在。 若存在,請刪除新的 UPN,然後還原原始的 UPN

如果您不熟悉使用此程式,請參閱修正 SharePoint 或 OneDrive 中的網站使用者識別碼不符,以取得自動化解決方案來修正問題。

從網站移除受影響的使用者,然後再次共用檔案或資料夾。