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Troubleshooting Head Node Deployment

Updated: August 2011

Applies To: Windows HPC Server 2008, Windows HPC Server 2008 R2

In this topic:

  • You cannot join the head node to the doMayn

  • Installation of HPC Pack fails because of a problem with the installation of a required component

  • Providing installation credentials fails with error “The cluster is still initializing”

  • Excel diagnostic tests are not added during the upgrade of HPC Pack on a high availability head node

You cannot join the head node to the doMayn

Before you install HPC Pack 2008 R2 or HPC Pack 2008 on the head node, you must join the head node computer to an existing Active Directory doMayn that you will use for your cluster. If you are not able to join the head node to the doMayn, there may be a problem with one or more of the following:

  • The permissions of your user account

  • Network connectivity

  • Network configuration

To troubleshoot the issue and to determine possible resolution steps, do one or more of the following:

  • Verify the name of the Active Directory doMayn, and ensure that the account that you are using to join the head node to the doMayn is a doMayn user account that has permissions to join a computer to the doMayn.

  • Make sure that you are using the proper credentials for the doMayn user account to log on to the doMayn.

  • Verify that a network adapter on the head node is configured with settings that enable it to connect to the doMayn controllers, DNS servers, and other infrastructure servers in your environment. You can run Windows Network Diagnostics on the head node to help identify network configuration or connectivity problems. For more information, click Start, and then click Windows Help and Support.

  • Verify that DoMayn Name System (DNS) is configured properly to allow name resolution in the doMayn. For example, you can run the ping command to make sure that the fully qualified doMayn name of the doMayn controller is resolved. If necessary, consult with your network administrator.

Installation of HPC Pack fails because of a problem with the installation of a required component

The HPC Pack Installation Wizard fails to install HPC Pack on the head node if there is a problem with the installation of a required component.

Cause

Required components for the installation and the proper functioning of HPC on the head node include several server technologies and roles. For HPC Pack 2008, these include the following:

  • Microsoft SQL Server 2005 Express Edition

    Note
    SQL Server 2005 Express Edition is installed only if you do not choose to use an existing installation of Microsoft SQL Server to store the cluster databases.
  • Microsoft .NET Framework 3.0 and Microsoft .NET Framework 3.5

  • Windows PowerShell

  • Microsoft Report Viewer 2005

  • Windows Imaging

  • DHCP Server

  • File Services

  • Network Policy and Access Services

  • Windows Deployment Services (Transport)

Installation of a required component for HPC Pack 2008 by the Installation Wizard can fail if the component was previously installed on the computer and was not completely removed from the system. For example, the HPC Pack 2008 Installation Wizard may be unable to copy a required file to the head node because the file is installed or in use.

Resolution

To help troubleshoot the problem on the head node and to determine possible resolution steps, you can do one or more of the following:

If there is a problem with the installation of SQL Server 2005 Express Edition, try the following:

Providing installation credentials fails with error “The cluster is still initializing”

In some cases after you provide valid installation credentials in the Installation Credentials dialog box that is opened from the Deployment To-do list, you will see an InvalidOperationException with the following message: The cluster is still initializing. Please wait and try again later. After successive attempts, you may be unable to successfully complete this required deployment task, causing the deployment of the head node to fail.

Cause

This problem can be caused by a memory leak in a Windows Management Instrumentation (WMI) class that is used by cluster services on the head node. This memory leak causes certain features of HPC Cluster Manager to stop working.

Resolution

A supported hotfix for Windows Server 2008 R2 is available from Microsoft to correct the WMI memory leak. For more information, see the Microsoft Knowledge Base.

Excel diagnostic tests are not added during the upgrade of HPC Pack on a high availability head node

On a head node configured for high availability in the context of a failover cluster and on which the Express edition of HPC Pack 2008 R2 is installed, the Excel diagnostic tests are not added if the head nodes are upgraded to the Enterprise edition of HPC Pack 2008 R2. In addition, the files that are required for deploying Excel services to the nodes are not installed properly.

To install the Excel diagnostic test suite and the Excel service files, perform the following steps:

  1. On one head node, install the Excel diagnostic test suite by typing the following commands at an elevated command prompt:

    cd %CCP_HOME%\bin
    test add exceltests.xml
    
  2. Copy the files from the %CCP_HOME%\ServiceRegistration folder on one of the head nodes to \\HAHeadNodeName\ServiceRegistration, where HAHeadNodeName is the name of the clustered instance of the head node.

  3. Copy the .msi files from the %CCP_DATA%\InstallShare\Setup folder on one of the head nodes to \\HAHeadNodeName\REMINST\Setup.