影響輸出直接路由呼叫的問題
當您使用直接路由從 Microsoft Teams 用戶端對會話邊界控制器進行連出呼叫時,可能會遇到各種問題 (SBC) 。 這些問題包括:
- 通話收件者會顯示不正確的來電者標識碼。
- 未建立與 SBC 的連線。
- 租使用者中的某些用戶無法撥打電話。
- 租用戶中沒有任何使用者可以撥打電話。
本文討論這些問題的潛在原因,並提供您可以嘗試的解決方法。
顯示給收件者的不正確來電者標識碼
當您使用直接路由時,會話初始通訊協定 (SIP) 選項訊息中的 和 P-Asserted-Identity
標頭中From
會列出傳遞給來電收件者的來電者標識符資訊。
標 From
頭包含下列任何專案:
- 指派給正在起始通話之來電者的電話號碼。 如果必須對來電收件者隱藏來電者的電話號碼,則會以「匿名」取代。
- 使用
CsCallingLineIdentity
Cmdlet 指派給呼叫端的服務號碼。 - 如果已轉接電話,則為原始來電者的電話號碼。
標 P-Asserted-Identity
頭包含付費用戶的電話號碼。 如果 Privacy:id
已設定,這表示必須在呼叫收件者中隱藏標頭中的資訊。
原因
如果和 P-Asserted-Identity
標頭中的From
資訊不相符,而且如果公用電話交換網 (PSTN) P-Asserted-Identity
優先處理標頭資訊,From
則會顯示不正確的資訊。
解決方案
若要確定已向通話收件者顯示正確的來電者標識符,請將 SBC 設定為從 SIP 選項訊息中移除 P-Asserted-Identity
標頭,或修改其內容。
未建立與 SBC 的連線
有時候,呼叫會連線到 SBC,但不會建立連線。 在此情況下,當 SBC 收到來自 Teams 的 SIP 選項訊息時,它會傳回失敗訊息,其中包含 400 到 699 範圍內的錯誤碼。
下列任何原因都可能會導致無法連線到 SBC。
原因 1
SIP 失敗訊息是由與 SBC 位於相同網路上的另一個電話語音裝置所產生。
解決方案 1
針對其他裝置進行疑難解答以修正錯誤。 如果您需要協助,請連絡裝置廠商。
原因 2
您的 PSTN 提供者遇到一些問題,並正在傳送 SIP 失敗訊息。 如果失敗錯誤碼為SIP 403 或 SIP 404,則最有可能發生這種情況。
解決方案 2
請連絡您的 PSTN 提供者以取得支援以修正此問題。
原因 3
此問題不是由網路上的另一部裝置或您的 PSTN 提供者所造成。 不過,原因不明。
解決方案3
請連絡 SBC 廠商以取得支援以修正此問題。
有些用戶無法撥打電話
如果 Teams 用戶端與 SBC 之間的連線正常運作,但某些使用者無法撥打電話,則問題可能是因為這些使用者的設定不正確或布建不正確所造成。
原因 1
使用者在 Teams 的 [ 通話 ] 索引標籤上遺漏撥號台。
解決方案 1
請確定使用者具有正確的授權 (E3 與電話系統或 E5) 和所有必要的設定。 若要檢查設定,請在Teams PowerShell 中執行 Get-CsOnlineUser Cmdlet,如下所示:
Get-CsOnlineUser -Identity <UserIdParameter> | fl Identity,EnterpriseVoiceEnabled,HostedVoiceMail,OnPremLineURI
所有必要值都必須指定,如 啟用使用者直接路由、語音和語音信箱中所述。
原因 2
在線語音路由原則 (OVRP 中沒有任何模式) 符合使用者撥號的號碼。
解決方案 2
請確定下列條件成立:
- OVRP 中有符合撥號的模式。
- 呼叫的使用配置檔符合為特定用戶設定的配置檔。
- 已啟用為 SBC 指定的閘道。 如果已停用,請加以啟用,或選取已啟用的不同閘道。
原因 3
使用者的 OVRP 包含無效的字元。
解決方案3
當您從 Microsoft Word 或其他 WYSIWYG 編輯器將資訊貼入 OVRP 時,可以在 OVRP 中插入無效、不可見的字元。 雖然不會顯示字元,但在決定呼叫應採用的路由時,會考慮這些字元。
若要修正此問題,請移除原則,然後手動重寫原則或從非 WYSIWYG 編輯器複製它,例如記事本來重新建立原則。
沒有使用者可以撥打電話
如果沒有任何用戶能夠撥打電話,則呼叫可能無法連線到 SBC。 檢查下列其中一個原因。
原因 1
Teams 有停用的閘道。
解決方案 1
使用 Microsoft Teams 系統管理中心,確定 Teams 所使用的閘道可供使用並啟用。
您也可以視需要使用 Teams PowerShell 來檢查和更新閘道。
若要檢查閘道的狀態,請執行 Get-CsOnlinePSTNGateway Cmdlet。 輸出必須顯示 參數的 Enabled
值設定為 True
。 在下列範例中,閘道的 Enabled
參數會設定為 sbc1.contoso.com
,但閘道的 參數則不會設定True
為 sbc2.contoso.com
。
Get-CsOnlinePSTNGateway | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
若要確定 sbc2.contoso.com
閘道可供 Teams 使用,請執行 Set-CsOnlinePSTNGateway Cmdlet,將 參數設定 Enabled
為 True
。
Set-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" -Enabled $true
若要檢查閘道現在是否 sbc2.contoso.com
可用,請再次執行 Get-CsOnlinePSTNGateway
Cmdlet:
Get-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
如需詳細資訊,請 參閱將 SBC 連線到直接路由。
原因 2
網關沒有回應 SIP 選項訊息,因為網路上的某些裝置,例如防火牆,會封鎖訊息。
解決方案 2
請確定所有將 SBC 連線到因特網的網路裝置上都允許 SIP 訊號 IP 和 FQDN。 必須允許的IP位址會列在 SIP Signaling: FQDN。
其他相關資訊
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