修正當您嘗試連線至 Microsoft 365 服務時,在 Office 應用程式中發生的驗證問題
徵狀
某些 Microsoft Office 應用程式中的驗證會自動失敗,Outlook 可能會進入「需要密碼」狀態,而不需要任何互動。 此外,當您對 FindAllAccountsAsync 進行 Web 帳戶管理員 API 呼叫時,您可能會在 Microsoft Entra 記錄或 Office 用戶端記錄中看到錯誤碼 “-2147024809”。
重要事項
此問題只會發生在執行 Windows 10、版本 1703 或更新版本,以及 Microsoft 365 1807 版或更新版本的電腦上。
原因
發生驗證問題是因為缺少 Active Directory 驗證程式庫 (ADAL) 或即時識別碼的套件資訊。
解決方案
提示
若要診斷並自動修正幾個常見的 Office 登入問題,您可以下載並執行 Microsoft 支援服務和修復小幫手] 。
若要修正此問題,請使用PowerShell針對組織或工作帳戶重新安裝 Microsoft Entra WAM 外掛程式 (的套件,) 個人帳戶的即時識別碼 (,例如 @outlook.com、 @hotmail.com等) 。 如果要執行這項操作,請依照下列步驟執行:
以滑鼠右鍵按一下工作列中的 Windows 圖示,然後選取 [Windows PowerShell(管理員)]。
如果使用者帳戶控制 (UAC) 視窗提示您,請選取 [是] 以啟動 PowerShell。
如果您的問題與工作帳戶有關,您必須修正 Microsoft Entra WAM 外掛程式套件。 在命令列執行以下命令:
if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
如果您的問題與個人帳戶有關,您必須修正即時識別碼套件。 在命令列執行以下命令:
if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
在您執行命令之後,如果命令完成而未發生錯誤,您可能會看到快速進度指標,或包含套件安裝相關資訊的狀態結果。