針對網域設定問題進行疑難解答
本指南說明如何解決設定和使用 Azure 電子郵件通訊服務的自定義網域的常見問題。
1.無法驗證自定義網域狀態
您必須將 TXT 記錄新增至網域註冊機構或功能變數名稱系統 (DNS) 主機提供者,以確認網域的擁有權。 如果網域驗證因任何原因而失敗,請完成本節中的下列步驟,以識別並解決基礎問題。
原因
驗證程式啟動之後,Azure 電子郵件通訊服務會嘗試從您的自定義網域讀取 TXT 記錄。 如果 Azure 電子郵件通訊服務無法讀取 TXT 記錄,則會將驗證狀態標示為失敗。
解決步驟
從電子郵件服務複製建議的 TXT 記錄,從 Azure 入口網站。 您的 TXT 記錄應該類似下列範例:
ms-domain-verification=43d01b7e-996b-4e31-8159-f10119c2087a
如果您尚未新增 TXT 記錄,則必須將 TXT 記錄新增至網域的註冊機構或 DNS 主機服務提供者。 如需逐步指示,請參閱 快速入門:如何新增自定義已驗證的電子郵件網域。
新增 TXT 記錄之後,您可以查詢自訂網域的 TXT 記錄。
nslookup
使用 Windows CMD 終端機的工具,從您的網域讀取 TXT 記錄。使用第三方 DNS 查閱工具:
在本節中,我們會繼續使用
nslookup
方法。使用下列
nslookup
命令來查詢 TXT 記錄:nslookup -q=TXT YourCustomDomain.com
查詢
nslookup
應該會傳回如下的記錄:檢閱自定義網域的 TXT 記錄清單。 如果您沒有看到您的 TXT 記錄列出,Azure 電子郵件通訊服務就無法驗證網域。
2.無法驗證 SPF 狀態
驗證網域狀態之後,您必須確認寄件者原則架構 (SPF) 和 DomainKeys 識別的郵件 (DKIM), 和 DKIM2。 如果您的SPF狀態失敗,請遵循下列步驟來解決問題。
從 Azure 入口網站 複製您的SPF記錄。 您的SPF記錄看起來應該像這樣:
v=spf1 include:spf.protection.outlook.com -all
Azure 電子郵件通訊服務會要求您將 SPF 記錄新增至網域的註冊機構或 DNS 主機服務提供者。 如需提供者清單,請參閱 在熱門網域註冊機構中新增 DNS 記錄。
新增SPF記錄之後,您可以查詢自訂網域的SPF記錄。 以下是兩種方法:
使用
nslookup
Windows CMD 終端機的工具,從您的網域讀取 SPF 記錄。使用第三方 DNS 查閱工具:
在本節中,我們會繼續使用
nslookup
方法。使用下列
nslookup
命令來查詢 SPF 記錄:nslookup -q=TXT YourCustomDomain.com
此查詢會傳回自定義網域的 TXT 記錄清單。
檢閱自定義網域的 TXT 標頭清單。 如果您沒有看到此處列出的SPF記錄,Azure電子郵件通訊服務無法驗證自定義網域的SPF狀態。
-all
檢查您的SPF記錄。如果您的SPF記錄包含
~all
SPF驗證失敗。Azure 通訊服務 需要
-all
而不是~all
驗證您的SPF記錄。
3.無法驗證 DKIM 或 DKIM2 狀態
如果 Azure 電子郵件通訊服務無法驗證 DKIM 或 DKIM2 狀態,請遵循下列步驟來解決問題。
開啟命令提示字元並使用
nslookup
:nslookup set q=TXT
如果 DKIM 失敗,請使用
selector1
。 如果 DKIM2 失敗,請使用selector2
。selector1-azurecomm-prod-net._domainkey.contoso.com
selector2-azurecomm-prod-net._domainkey.contoso.com
此查詢會傳回自定義網域的 CNAME DKIM 記錄。
如果
nslookup
傳回 CNAME DKIM 或 DKIM2 記錄,類似於上圖,則您可以預期 Azure 電子郵件通訊服務驗證 DKIM 或 DKIM2 狀態。如果輸出中遺漏
nslookup
DKIM/DKIM2 CNAME 記錄,則 Azure 電子郵件通訊服務無法驗證 DKIM 或 DKIM2 狀態。如需提供者清單,請參閱 CNAME 記錄。