Troubleshooting 04-0000180C / 6156 Errors in Microsoft Application Virtualization
Here’s a new Knowledge Base article we published today. This one talks about troubleshooting an issue where attempting to upgrade a package in Microsoft Application Virtualization (App-V) fails with error 04-0000180C:
=====
Symptoms
Attempting to upgrade a package in Microsoft Application Virtualization (App-V) fails with error 04-0000180C:
C:\Program Files (x86)\Microsoft Application Virtualization Client>sftmime.com add package:" APP_V1.1" /manifest "C:\\Program Files (x86)\\SMS_CCM\\Cache\\ABC00076.2.S-1-5-21-1111111111-1111111111-1111111111-500\\APP_V1.1 _manifest.xml" /overrideUrl "FILE://C:\\Program Files (x86)\\SMS_CCM\\Cache\\ABC00076.2.S-1-5-21-1111111111-1111111111-1111111111-500\\ABC00076.sft"
The Application Virtualization Client could not complete
the operation.
The operation failed because the GUID in the package
manifest matches a package name other than the one
specified. Verify the package name, and then try again.
Error code: 4605F3-18305104-0000180C
For System Center Configuration Manager (CfgMgr) clients, the VirtualApp.log will show entries similar to the following, exiting with error code 6156 (SWRC_PKG_NAMEDOESNOTMATCH):
<![LOG[Executing command line: "C:\Program Files\Microsoft SoftGrid\Microsoft SoftGrid Application Virtualization for Desktops\SFTMIME.COM" ADD PACKAGE:"Package1" /MANIFEST "C:\\WINDOWS\\system32\\CCM\\Cache\\ABC00500.3.S-1-5-21-1111111111-1111111111-1111111111-2672\\Package1.xml" /OverrideUrl "FILE://C:\\WINDOWS\\system32\\CCM\\Cache\\ABC00500.3.S-1-5-21-1111111111-1111111111-1111111111-2672\\ABC00500.sft"]LOG]!><time="16:37:46.837+-120" date="08-08-2008" component="VAppRegistration" context="" type="1" thread="3120" file="registrationhandler.cpp:1031">
<![LOG[The command completed with exit code 6156.]LOG]!><time="16:37:47.368+-120" date="08-08-2008" component="VAppRegistration" context="" type="1" thread="3120" file="registrationhandler.cpp:1140">
Cause
This error indicates that there is a mismatch between the package name of the original package and that of the upgraded package. This results in the App-V client incorrectly determining that there is a duplicate GUID, since the package GUID in both manifests will be the same. To successfully upgrade a package, both of the following conditions must be true:
1. The package GUID must be the same (the Version tag and VERSIONGUID tag will change).
2. The package name must be exactly the same. This can be verified by opening the original and upgrade package's manifest XML in a text editor to compare the NAME and GUID tags.
The NAME tag is derived from the Package Name field on the General Properties tab of the package. The App-V Sequencer allows this field to be changed after sequencing a package but before saving the files. To avoid this error, do not edit this field.
In a second variation, the Microsoft System Center Configuration Manager (ConfigMgr) Virtual Application Package Update Wizard allows for the Name: field to be changed on its General page. Editing the Name: or Version: fields of the New Package's values will result in the errors above.
Resolution
To avoid the 04-0000180C and 6156 errors listed above, do not change the package name in either the App-V Sequencer or the ConfigMgr Virtual Application Package Update Wizard. If the package manifest file is correct, simply re-run the Virtual Application Package Update Wizard without changing any values. If the package name has been changed in the Sequencer, re-sequence the application and do not change this value.
=====
For the most current version of this article please see the following:
2688524 : Troubleshooting 04-0000180C / 6156 Errors in Microsoft Application Virtualization
J.C. Hornbeck | System Center & Security Knowledge Engineer
Get the latest System Center news on Facebook and Twitter :
App-V Team blog: https://blogs.technet.com/appv/
ConfigMgr Support Team blog: https://blogs.technet.com/configurationmgr/
DPM Team blog: https://blogs.technet.com/dpm/
MED-V Team blog: https://blogs.technet.com/medv/
Orchestrator Support Team blog: https://blogs.technet.com/b/orchestrator/
Operations Manager Team blog: https://blogs.technet.com/momteam/
SCVMM Team blog: https://blogs.technet.com/scvmm
Server App-V Team blog: https://blogs.technet.com/b/serverappv
Service Manager Team blog: https://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: https://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: https://blogs.technet.com/sus/
The Forefront Server Protection blog: https://blogs.technet.com/b/fss/
The Forefront Endpoint Security blog : https://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : https://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: https://blogs.technet.com/b/isablog/
The Forefront UAG blog: https://blogs.technet.com/b/edgeaccessblog/