Error: HP Universal Printing | Invalid Address when using the Hewlett-Packard Universal Printer Drivers with Microsoft Application Virtualization
Here’s one more new KB article we published this morning. This one talks about how to allow App-V clients to print to HP UPD printers:
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Symptoms
When using the Hewlett-Packard Universal Printer Drivers (HP UPD) with the Microsoft Application Virtualization (App-V) client and trying to configure a printer through the Enter a Printer Address... dialog box, you receive the following error:
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Error: HP Universal Printing
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Invalid Address.
Verify and re-enter the address, or use a different address.
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OK
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Cause
This behavior is by design. By default, App-V does not allow access to global objects such as semiphores and mutexes from within App-V. These objects must be explicitly excluded.
Resolution
To allow App-V clients to print to HP UPD printers use the following steps:
Upgrade the client to App-V 4.6 SP1 or greater. This is required as it includes several necessary fixes.
Open Regedit and navigate to the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions
On 64-bit machines, this will be located at:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions
Note the highest numbered REG_SZ value in the list of ObjExclusions. In this example, we will assume that the highest number is 93. Increment this number by 1 and add the a new REG_SZ value with this name (i.e. REG_SZ, name: 94). Double-click on the value and enter the value data Global\* .
Repeat this process by again incrementing the number and adding value data *HPZ*
For example, add values 94 and 95 where the highest ObjExclusions value is 93:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\SystemGuard\ObjExclusions]
"0"="SFT-"
"1"="SWPLAY"
<SNIP>
"93"="FntCache*"
94"="Global\\* "
"95"="*HPZ* "
More Information
Note that this solution assumes that the printer is otherwise accessible and that other, identical clients are able to connect to the printer.
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For the most current version of this article please see the following:
J.C. Hornbeck | System Center Knowledge Engineer
App-V Team blog: https://blogs.technet.com/appv/
AVIcode Team blog: https://blogs.technet.com/b/avicode
ConfigMgr Support Team blog: https://blogs.technet.com/configurationmgr/
DPM Team blog: https://blogs.technet.com/dpm/
MED-V Team blog: https://blogs.technet.com/medv/
OOB Support Team blog: https://blogs.technet.com/oob/
Opalis Team blog: https://blogs.technet.com/opalis
Orchestrator Support Team blog: https://blogs.technet.com/b/orchestrator/
OpsMgr Support Team blog: https://blogs.technet.com/operationsmgr/
SCMDM Support Team blog: https://blogs.technet.com/mdm/
SCVMM Team blog: https://blogs.technet.com/scvmm
Server App-V Team blog: https://blogs.technet.com/b/serverappv
Service Manager Team blog: https://blogs.technet.com/b/servicemanager
System Center Essentials Team blog: https://blogs.technet.com/b/systemcenteressentials
WSUS Support Team blog: https://blogs.technet.com/sus/
Comments
Anonymous
January 01, 2003
So does this apply both for 4.5 and 4.6 RTM?Anonymous
March 19, 2013
Is this from within an App-V application or is this if you using the universal drivers for your printers and then trying to print from an App-V application. A little more detail would help. We use the universal drivers and have never seen this issue.