Salesforce CRM 用户无法在 Copilot for Sales 中看到数据

本文可帮助你排查并解决用户无法在 Microsoft Copilot for Sales 中看到数据的问题。

注意

Microsoft Sales Copilot 在 2024 年 1 月被改名为 Microsoft Copilot for Sales。 本文中的屏幕截图将很快更新为新名称。

谁受影响?

要求类型 Description
客户端应用 Copilot for Sales Outlook 加载项
平台 Web 和桌面客户端
操作系统 Windows 和 Mac
部署 用户管理和管理员管理
CRM Salesforce
用户 无权查看 Copilot for Sales 窗体中添加的字段的用户

现象

当用户在 Outlook 中打开 Copilot for Sales 时,将显示以下错误消息:

出现问题

显示“出现问题”错误的详细信息的屏幕截图。

原因

字段的字段级别安全性设置为在 Salesforce CRM 中不可见。 因此,Copilot for Sales 无法按预期在配置中引用该字段。

解决方法 1:修复 Salesforce CRM 中的字段级安全性

  1. 以管理员身份登录到 Salesforce CRM 并打开 安装程序

  2. 打开对象管理器

  3. 选择引发错误的实体。

  4. 在左侧导航栏中,选择“ 字段和关系”。

  5. 选择引发错误的字段。

  6. 选择顶部的设置字段级安全性

    显示 Salesforce CRM 中的对象管理器的屏幕截图。

  7. 确保为正确的配置文件设置可见

  8. 对自定义权限集进行相同验证。

有关 Salesforce CRM 中字段级安全性的详细信息,请参阅 字段级别安全性

解决方法 2:更改 Copilot for Sales 中的设置以隐藏字段或删除编辑功能

从 Microsoft Teams 中的 Copilot for Sales 管理员设置更改管理员设置,以隐藏字段或删除编辑功能。

  1. 使用管理员凭据登录到 Microsoft Teams。

  2. 在左侧导航栏中,选择 “Copilot for Sales”。

  3. “设置” 选项卡上,选择“ 窗体”。

  4. 选择您看到错误的实体。

  5. 管理字段下,执行下列操作之一:

    • 如果问题与编辑字段有关,请关闭 “允许编辑 相应字段”。

      显示如何关闭“管理字段”页上几个字段的编辑的屏幕截图。

    • 如果问题与查看字段有关,请将鼠标悬停在该字段上,然后选择“ 删除”字段 )。

  6. 选择发布保存您所做的更改。

解决方法 3:从 CRM 刷新数据

如果不知道哪个字段导致问题,可以从 CRM 刷新数据 。 此操作会将从 CRM 到 Copilot for Sales 的最新更改同步,并删除从 CRM 中删除但仍可在 Copilot for Sales 中删除的任何字段。 刷新数据后,必须在 Outlook 中关闭并重新打开 Copilot for Sales 加载项。

详细信息

如果你的问题仍未解决,请转到 Copilot for Sales - Microsoft社区中心 与我们的专家联系。

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