Configuration Manager 服务连接点不会下载更新
本文可帮助你修复服务连接点无法下载更新的问题。 当 Baltimore CyberTrust 根证书缺失、过期或损坏时,会出现此问题。
原始产品版本: Configuration Manager(Current Branch),Microsoft Intune
原始 KB 数: 3187516
现象
在 Configuration Manager Current Branch 环境中运行的服务连接点不会下载更新,类似以下内容的条目将记录DMPDownloader.log:
下载manifest.cab SMS_DMP_DOWNLOADER 2016/8/2 下午 2:20:24 7568 (0x1D90)
警告:无法下载简单的安装有效负载(异常):基础连接已关闭:无法为 SSL/TLS 安全通道建立信任关系。 SMS_DMP_DOWNLOADER 2016/8/2 下午 2:20:25 下午 10760 (0x2A08)
警告:在下一轮投票周期重试,SMS_DMP_DOWNLOADER 2016/8/2 下午 2:20:25 下午 10760 (0x2A08)
使用 Microsoft Intune 时,还可能会注意到客户端连接问题。
原因
服务连接点连接到 http://go.Microsoft.com https://manage.Microsoft.comIntune 服务时使用 Intune 服务。 如果 Baltimore CyberTrust 根证书缺失、过期或损坏,则 Intune 连接尝试将被拒绝。
解决方法
这是 Intune 的已知问题,如未安装 Baltimore CyberTrust 根证书时连接问题中所述。 但是,此更新不再显示在Microsoft更新目录中。
解决方法是,可以从环境中的证书颁发机构导出证书。
获取证书后,必须导入它。 要导入证书,请按照下列步骤操作:
- 使用管理权限打开命令提示符(以管理员身份运行)。
- 运行
mmc
命令。 - 在“文件”菜单中,选择“添加/删除管理单元”。
- 选择“证书”,然后选择“添加”。
- 选择 “计算机帐户”,然后选择“ 下一步”。
- 选择 “本地计算机”,选择“ 完成”,然后选择“ 确定”。
- 在控制台树中,展开“证书>受信任的根证书颁发机构>证书”。
- 右键单击“证书”,然后选择“导入”。
- 导入 Baltimore CyberTrust 根证书。
- 重新启动计算机。
现在,应在受信任的根证书颁发机构下看到 Baltimore CyberTrust Root 的条目:
详细信息
如果未安装 Baltimore CyberTrust 根证书、过期或正在使用 Intune 的计算机上损坏,Intune 连接器将遇到连接问题。
有关此问题的详细信息,请参阅 未安装 Baltimore CyberTrust 根证书时可能出现连接问题。