解决应用内市场营销问题
本文可帮助你排查和解决与应用内营销相关的问题。
问题 1 - 打开“市场营销列表”窗体时,成员视图不可用
原因
由于自定义“市场营销列表”窗体中每个子网格的视图,导致成员列表显示为空,因此出现问题。
解决方法
转到“高级设置设置>自定义>”自定义>系统。
从网站地图中,打开“实体>营销列表>表单”。
从表单列表中,选择“ 市场营销列表 ”窗体。
在“市场营销列表”窗体的“市场营销列表”网站地图中,选择“成员”。
选择“联系人”,然后选择“更改属性”。 设置属性窗口将打开。
在 “其他选项” 部分的 “视图选择器 ”下拉列表中,选择“ 显示所选视图”。
将显示其他选项的列表。
选择 “我的活动联系人 ”视图,然后从 “视图选择器 ”下拉列表中选择“ 关闭”。
在“ 名称 ”部分中,清除 “窗体 ”复选框上的“显示”标签。
选择“确定”。
对 帐户 和 潜在顾客重复步骤 5 到 9。
保存并发布窗体。
问题 2 - 无法将从“市场营销列表”表单创建的市场活动与统一界面中的市场营销列表记录相关联
原因
之所以出现此问题,是因为属性 TmpRegardingObjectId 已从 Campaigns 窗体中删除。
解决方法
转到“高级设置设置>自定义>”自定义>系统。
在网站地图中,打开“实体>市场活动>表单”。
从表单列表中,选择“市场活动”窗体。
在页面右侧显示的“字段资源管理器”窗格中,将字段 TmpRegardingObjectId 添加到窗体。
选择 TmpRegardingObjectId 字段,然后选择“ 更改属性”。
设置属性窗口将打开。
在“ 标签 ”部分中,清除 “窗体 ”复选框上的“显示标签”,在 “可见性 ”部分中,清除 “可见”默认 复选框。
保存并发布窗体。
问题 3 - 在统一接口中使用高级查找找不到成员帐户的相关帐户字段
原因
出现此问题的原因是应用程序中已更改联系人或帐户显示名称,并且 公司名称(RELATED_TYPE) 从更改的显示名称中选择相关类型。
解决方法
在统一接口中,公司名称实体以公司名称(帐户)的形式提供。 例如,如果将帐户重命名为组织,实体将重命名为公司名称(组织)。
问题:无法使用电子邮件快速市场活动通讯组列表发送电子邮件
原因
由于以下原因之一,出现此问题:
- 用户无权代表其他用户发送电子邮件。
- 记录(营销列表成员)的所有者不允许其他 Dynamics 365 用户代表所有者发送电子邮件。
解决方法
要解决此问题,请执行下列两项操作之一:
对于创建快速市场活动的用户, 必须将“发送电子邮件为其他用户 ”权限分配给至少一个角色。 有关详细信息,请参阅 创建具有团队成员特权继承的安全角色。
对于记录的所有者,必须在“选择其他用户是否可以在”设置个人选项“对话框中为你发送电子邮件下选中”允许其他Microsoft Dynamics 365 用户代表你发送电子邮件“复选框。
问题 4 - 无法在快速市场活动向导中更改电子邮件中的表单字段
原因
此问题是由于“发送电子邮件”权限 不足,作为角色的另一个“用户 ”选项造成的。
解决方法
为 “发送电子邮件”提供足够的权限作为另一个角色 之一的用户选项。
问题 5 - 在“分发”对话框中看不到电子邮件模板
原因
统一接口中的电子邮件模板选择器依赖于不同实体的某些访问级别。
解决方法
若要解决此问题,用户需要访问系统用户记录。 通过在 Dynamics 365 组织中分配系统用户的安全角色来提供对系统用户的访问权限。 有关详细信息,请参阅 配置环境中的资源的用户安全性。
问题 6 - 市场活动分发过程停滞在“挂起”或“失败”状态
原因
市场活动分发过程需要一个工作流才能在后台运行。 禁用工作流后,市场活动分发将不会完成,并且会卡在 “挂起 ”或 “ 失败”状态。
解决方法
若要解决此问题,请启用工作流后台进程,然后激活 ActivityPropagation 进程。
启用工作流后台进程
转到高级设置设置>>系统>作业。
转到 ActivityPropagation 作业并在“进程会话”下,选择匹配或近似匹配的作业、运行快速市场活动的日期和时间。
验证详细信息部分下是否显示错误消息,指出由于组织处于 禁用后台处理 模式,因此跳过了异步操作。 通过执行以下操作更新环境的设置:
转到 Dynamics 365 管理中心,选择实例,然后选择“管理员设置”。
清除“ 禁用后台操作 ”复选框。
保存设置,然后退出。
激活 ActivityPropagation 过程
转到“高级设置设置>自定义>”自定义>系统。
从站点地图中,转到 “进程”。
在视图选择器中,选择“ 全部”。
将显示所有可用的进程。
选择 ActivityPropagation 过程,然后选择“ 激活”。
问题 7 - 我的快速市场活动失败,它设置为“中止”
原因
此问题是由与工作流进程中的自定义插件相关的堆栈跟踪失败引起的。
解决方法
- 转到高级设置设置>>系统>作业。
- 转到 ActivityPropagation 作业并在“进程会话”下,选择匹配或近似匹配的作业、运行快速市场活动的日期和时间。
系统作业包含包含失败的堆栈跟踪的信息。 解决堆栈跟踪失败文档中提到的故障。
问题 8 - 快速市场活动正在执行不可阻止的循环并生成数千条失败记录
原因
由于未知条件,当工作流无法创建活动活动时,它将进入不可阻挡的循环,并不断创建活动活动,这一切都失败。 你将看到失败次数不断增加,直到超过目标营销列表中的成员数。
解决方法
停用 ActivityPropagation 工作流,然后再次激活它。
转到“高级设置设置>自定义>”自定义>系统。
从站点地图中,转到 “进程”。
在视图选择器中,选择“ 全部”。
将显示所有可用的进程。
选择 ActivityPropagation 工作流,然后选择“ 停用”。
等待 24 小时,然后重新激活 ActivityPropagation 工作流。
问题 9 - 市场活动分发不会在目标实体上创建活动
目标记录(帐户、联系人和潜在顾客)可以通过市场宣传来识别接收营销材料的偏好:其中包括电子邮件、电话、传真和批量邮件。
仅当市场营销列表成员的首选项设置为“允许”或“发送”时,才会为市场活动活动创建。
问题 10 - 某些成员的市场活动分发失败
原因
市场活动分发基于市场营销列表中的成员。 该成员可以是帐户、联系人或潜在顾客。 由于以下原因之一,市场活动分配可能会失败:
- 没有与成员关联的电子邮件地址。
- 与成员关联的电子邮件地址无效。
- 该成员已将成员记录中的“发送营销材料”字段配置为“不发送”。
解决方法
查看排除成员网格中失败的详细原因,并采取任何必要措施。
问题 11 - 统一界面中的帐户、联系人或潜在顾客表单中不提供“市场活动”选项卡
原因
由于市场活动表和帐户、联系人或潜在顾客之间没有直接关系,因此这些表单中不提供“ 市场活动 ”选项卡。 查看市场活动列表的唯一方法是通过分布式市场活动,因为分布式市场活动是目标实体在市场活动中使用的真实指示。
解决方法
若要解决此问题,请将“ 活动活动 ”选项卡添加到窗体。
注意
在此示例中,我们使用 Account 实体。
转到“高级设置设置>自定义>”自定义>系统。
在“组件”中,选择“实体>帐户>窗体”。
打开要向其添加子网格的窗体。
在窗体页上,选择“ 插入 ”选项卡,然后选择 “一列”。
将新列添加为选项卡。
选择选项卡,然后选择“ 更改属性”。 将打开选项卡属性对话框。
输入“名称”和“标签为市场活动”的值,然后选择“确定”。 然后,该选项卡将重命名为 活动活动。
选择“活动活动”选项卡,转到“插入”选项卡,然后选择“子网格”。
此时 会打开子网格的“设置属性 ”对话框。
在“ 显示 ”选项卡上,输入以下信息:
- 在 “名称 ”部分中,输入唯一名称 Campaign_Activities。
- 在“ 名称 ”部分的 “标签”中,输入 活动活动。
- 在 “数据源 ”部分中,执行以下操作:
- 对于 实体,请选择“ 活动活动”。
- 对于 默认视图,请选择“ 所有活动活动”。
保存更改并发布表单。
若要验证问题是否已解决,请打开已在市场活动中使用的帐户,并具有一些分布式市场活动。 选择“活动活动”选项卡以验证是否显示相关的活动活动。
问题 12 - 尝试删除静态营销列表时,用户将超时
原因
删除具有大量成员(超过 50,000 个)的静态营销列表需要很长时间,结果会超时。
解决方法
建议先使用“高级查找”从市场营销列表中删除所有成员,然后删除市场营销列表。 为了提高应用程序的性能并避免超时,请一次删除 10,000 组的营销列表中的成员。 例如,如果市场营销列表中有 20,000 个成员,并且你想要删除成员。 首先删除 10,000 个成员,然后删除其他 10,000 个成员。