排查应用内营销问题
本文可帮助你排查和解决与应用内营销相关的问题。
问题 1 - 打开“市场营销列表”窗体时,“成员”视图不可用
原因
此问题是由于自定义“市场营销列表”窗体中每个子网格的视图,导致成员列表显示为空。
解决方案
转到“高级设置设置”“>>自定义>系统”。
在站点地图中,打开 “实体>营销列表>窗体”。
从窗体列表中,选择“ 市场营销列表” 窗体。
在 “市场营销列表” 窗体的“ 市场营销列表” 站点地图中,选择“ 成员”。
选择“ 联系人”,然后选择“ 更改属性”。 “ 设置属性” 窗口随即打开。
在 “其他选项” 部分中,从“ 视图选择器 ”下拉列表中选择“ 显示所选视图”。
此时会显示其他选项列表。
选择 “我的活动联系人” 视图,然后从“ 视图选择器” 下拉列表中选择“ 关闭”。
在 “名称 ”部分中,清除“ 窗体”复选框上的“显示标签 ”。
选择“确定”。
对 帐户 和 潜在顾客重复步骤 5 到 9。
保存并发布表单。
问题 2 - 无法将从“市场营销列表”窗体创建的市场活动与统一接口中的市场营销列表记录相关联
原因
出现此问题的原因是属性 TmpRegardingObjectId 已从 Campaigns 窗体中删除。
解决方案
转到“高级设置设置”“>>自定义>系统”。
在站点地图中,打开 “实体>市场活动>表单”。
从表单列表中,选择 “市场活动 ”窗体。
在页面右侧显示的“ 字段资源管理器 ”窗格中,将字段 TmpRegardingObjectId 添加到窗体。
选择 “TmpRegardingObjectId ”字段,然后选择“ 更改属性”。
此时将打开“设置属性窗口。
在 “标签 ”部分中,清除“ 窗体上显示标签 ”复选框,在“ 可见性 ”部分中,清除 “默认可见 ”复选框。
保存并发布表单。
问题 3 - 在统一接口中使用高级查找找不到成员帐户的相关帐户字段
原因
出现此问题的原因是应用程序中的联系人或帐户显示名称已更改,并且 公司名称 (RELATED_TYPE) 从更改的显示名称中选取相关类型。
解决方案
在统一接口中,公司名称实体以 公司名称 (帐户) 提供。 例如,如果将 帐户 重命名为 组织,实体将重命名为 公司名称 (组织) 。
问题:无法使用电子邮件快速市场活动通讯组列表发送电子邮件
原因
出现此问题的原因是以下原因之一:
- 用户没有代表其他用户发送电子邮件的权限。
- 记录 (营销列表成员的所有者) 不允许其他Dynamics 365用户代表所有者发送电子邮件。
解决方案
要解决此问题,请执行下列两项操作之一:
对于创建快速市场活动的用户,必须将“以其他用户身份发送Email”权限至少分配给该用户一个角色。 有关详细信息,请参阅 使用团队成员的权限继承创建安全角色。
对于记录的所有者,必须在“设置个人选项”对话框的“选择其他用户是否可以为你发送电子邮件”下选中“允许其他 Microsoft Dynamics 365用户代表你发送电子邮件”复选框。
问题 4 - 无法在快速市场活动向导中更改电子邮件中的表单字段
原因
此问题是由于角色的“将Email作为另一个用户发送”选项的权限不足导致的。
解决方案
为其中一个角色的“将Email作为另一个用户发送”选项提供足够的权限。
问题 5 - 在分发对话框中看不到电子邮件模板
原因
统一接口中的电子邮件模板选择器依赖于不同实体的特定访问级别。
解决方案
若要解决此问题,用户需要访问系统用户记录。 通过在Dynamics 365组织中分配安全角色,为系统用户提供访问权限。 有关详细信息,请参阅 为环境中的资源配置用户安全性。
问题 6 - 市场活动分发过程停滞状态为“挂起”或“失败”
原因
市场活动分发过程需要在后台运行工作流。 禁用工作流后,市场活动分发不会完成,并且将停滞在 “挂起” 或 “失败” 状态。
解决方案
若要解决此问题,请启用工作流后台进程,然后激活 ActivityPropagation 进程。
启用工作流后台进程
转到“高级设置设置”“>>系统>系统作业”。
转到 ActivityPropagation 作业,在 “处理会话”下,选择匹配或近似匹配的作业,以及运行快速市场活动的日期和时间。
验证详细信息部分下是否显示错误消息,指出异步操作已跳过,因为组织处于 禁用后台处理 模式。 通过执行以下操作来更新环境的设置:
转到Dynamics 365管理中心,选择实例,然后选择“管理员设置”。
清除 “禁用后台操作 ”复选框。
保存设置,然后退出。
激活 ActivityPropagation 过程
转到“高级设置设置”“>>自定义>系统”。
在站点地图中,转到 “进程”。
在视图选择器中,选择“ 全部”。
将显示所有可用进程。
选择 ActivityPropagation 过程,然后选择 “激活”。
问题 7 - 我的快速市场活动失败,已设置为“中止”
原因
此问题是由与工作流过程中的自定义插件相关的堆栈跟踪失败引起的。
解决方案
- 转到“高级设置设置”“>>系统>系统作业”。
- 转到 ActivityPropagation 作业,在 “处理会话”下,选择匹配或近似匹配的作业,以及运行快速市场活动的日期和时间。
系统作业包含包含失败的堆栈跟踪的信息。 按照堆栈跟踪失败文档中所述解决失败问题。
问题 8 - 快速市场活动正在执行一个势不可挡的循环并生成数千条失败记录
原因
由于未知情况,当工作流无法创建市场活动时,它会进入一个不可阻挡的循环,并不断创建市场活动,而这些活动都失败了。 你将看到失败次数不断增加,直到超过目标营销列表中的成员数。
解决方案
停用 ActivityPropagation 工作流,然后再次激活它。
转到“高级设置设置”“>>自定义>系统”。
在站点地图中,转到 “进程”。
在视图选择器中,选择“ 全部”。
将显示所有可用进程。
选择 “ActivityPropagation ”工作流,然后选择“ 停用”。
等待 24 小时,然后重新激活 ActivityPropagation 工作流。
问题 9 - 市场活动分发不会在目标实体上创建活动
目标记录 (帐户、联系人和潜在顾客) 可以确定其通过市场活动分发接收营销材料的偏好:其中包括电子邮件、电话、传真和批量邮件。
仅当市场营销列表成员的首选项设置为 “允许” 或“ 发送”时,才会为其创建市场活动活动。
问题 10 - 某些成员的竞选活动分发失败
原因
市场活动分布基于市场营销列表中的成员。 该成员可以是帐户、联系人或潜在顾客。 由于以下原因之一,对于成员来说,市场活动分发可能会失败:
- 没有与成员关联的电子邮件地址。
- 与成员关联的电子邮件地址无效。
- 该成员已将成员记录中的“ 发送营销材料 ”字段配置为 “不发送”。
解决方案
在 “排除的成员” 网格中查看失败的详细原因,并采取任何必要的操作。
问题 11 - 统一接口的帐户、联系人或潜在顾客表单中不提供“市场活动”选项卡
原因
由于市场活动表与帐户、联系人或潜在顾客之间没有直接关系,因此“ 市场活动 ”选项卡在这些窗体中不可用。 查看市场活动列表的唯一方法是通过分布式市场活动,因为分布式市场活动是市场活动中使用的目标实体的真实指示。
解决方案
若要解决此问题,请将“ 市场活动 ”选项卡添加到窗体。
注意
在此示例中,我们使用 Account 实体。
转到“高级设置设置”“>>自定义>系统”。
在 “组件”中,选择“ 实体>帐户>窗体”。
打开要向其添加子网格的窗体。
在窗体页上,选择“ 插入 ”选项卡,然后选择“ 一列”。
新列将添加为选项卡。
选择选项卡,然后选择“ 更改属性”。 此时将打开 “选项卡属性 ”对话框。
输入 “名称 ”和“ 标签 为 市场活动”的值,然后选择“ 确定”。 然后,该选项卡将重命名为 市场活动。
选择“ 市场活动” 选项卡,转到“ 插入 ”选项卡,然后选择“ 子网格”。
此时会打开子网格的“ 设置属性 ”对话框。
在“ 显示 ”选项卡上,输入以下信息:
- 在 “名称” 部分中,输入唯一名称 Campaign_Activities。
- 在 “名称 ”部分的 “标签”中,输入 市场活动。
- 在 “数据源 ”部分中,执行以下操作:
- 对于“实体”,请选择“市场活动”。
- 对于 “默认视图”,请选择“ 所有市场活动”。
保存更改并发布表单。
若要验证问题是否已解决,请打开已在市场活动中使用的帐户,并具有一些分布式市场活动。 选择“ 市场活动 ”选项卡,验证是否显示相关的市场活动。
问题 12 - 用户在尝试删除静态营销列表时超时
原因
删除包含大量成员 (超过 50,000 个) 的静态营销列表需要很长时间,从而导致超时。
解决方案
建议先使用“ 使用高级查找删除”从市场营销列表中删除所有成员,然后删除营销列表。 为了提高应用程序的性能并避免超时,请删除营销列表中一次 10,000 个组的成员。 例如,如果市场营销列表中有 20,000 个成员,并且你想要删除这些成员。 首先删除 10,000 个成员,然后删除其他 10,000 个成员。