在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时,视图不可用错误

本文提供了解决“视图不可用”错误的解决方案,当您尝试在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时发生。

适用于: Microsoft Dynamics CRM Online
原始 KB 数: 4338690

现象

在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时,会看到以下错误:

“视图不可用。 请与您的系统管理员联系。”

原因

如果停用了 Microsoft Dynamics 365 App for Outlook 使用的视图之一,则可能会出现此错误。 Microsoft Dynamics 365 App for Outlook 使用特殊窗体显示潜在顾客(Outlook 潜在顾客快速视图应用)或联系人(Outlook 联系人快速视图应用)信息。 每个窗体都包含引用特定视图的列表。 如果其中一个视图已停用,你可能会看到视图 不可用 错误。

解决方法

确保 Outlook 潜在顾客快速视图窗体和 Outlook 联系人快速视图窗体的应用使用的视图未停用。 当您在 Microsoft Dynamics 365 App for Outlook 中查看电子邮件时,所使用的表单取决于电子邮件是否来自潜在顾客或联系人。 如果仅当电子邮件来自联系人时看到此错误,则你可能需要修复联系人表单使用的视图。 如果仅当电子邮件来自潜在顾客时看到错误,则可能需要修复潜在顾客表单使用的视图。 在下面的示例中,我们将验证应用用于 Outlook 联系人快速视图窗体的默认视图是否已激活。 对于在潜在顾客实体(而不是联系人实体)下找到的 Outlook 潜在顾客快速视图窗体,可以使用类似的步骤:

  1. 作为具有系统管理员或系统定制器安全角色的用户,请打开 Microsoft Dynamics 365 Web 应用程序。
  2. 导航到 “设置” ,然后选择“ 自定义”。
  3. 选择自定义系统。 这将打开 “默认解决方案 ”对话框。
  4. 选择“实体,选择“联系人”,然后选择“窗体”。
  5. 打开“Outlook 联系人快速视图”窗体。 默认情况下,此窗体包含两个活动列表、机会列表和案例列表。 下表显示了列表的默认名称以及用于列表的默认视图。
  6. 可以使用这些表作为重新激活默认视图的参考。
  7. 在此示例中,我们将查看来自活动实体的前两个列表。 可以为其他提到的实体重复相同的步骤。
  8. 切换回 “默认解决方案 ”对话框,选择“ 活动”,然后选择“ 视图”。
  9. 选择“ 视图 ”下拉列表,然后选择“ 非活动公共视图”。
  10. 验证“下一活动”和“上次活动”视图未显示在“非活动公共视图”列表中。 如果停用这些视图中的任何一个,请选择它们,然后选择“ 激活”。
  11. 使用相同的步骤验证其他视图是否处于活动状态后,选择“ 发布所有自定义项”。
  12. 可能需要关闭并重新打开 Outlook,并可能清除浏览器缓存。

Outlook 联系人快速视图的应用

列表名称 默认视图 实体
下一个活动 下一个活动 活动
Last Activity Last Activity 活动
最近的机会 以交互为中心的表单的最新机会 商机
最近发生的案例 我的可用案例 案例

Outlook 潜在顾客快速视图窗体的应用

列表名称 默认视图 实体
下一个活动 下一个活动 活动
Last Activity Last Activity 活动
利益干系人 所有利益干系人 连接
竞争对手 所有竞争对手(摘要) 竞争对手

注意

如果要更改这些窗体使用的视图,而不是激活默认视图,可以打开窗体上列表节的属性以更改所选视图。 如果已停用其中一个默认视图,则实际上将无法看到列表引用它,即使它当前仍在引用该默认视图。 相反,它将显示一些其他处于活动状态的视图名称。 可能需要先将其更改为另一个视图,然后将其更改为想要选择的视图,以便更改生效。

Microsoft知道在尝试更改视图时可能会遇到错误的问题。 可以更改“下一活动”和“上次活动视图”,但在尝试更改其他视图时,遇到错误(发生错误。请返回到主页,然后重试。 Microsoft正在调查此问题的保护解决方案。