在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时视图不可用错误
本文提供了解决尝试在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时出现的“视图不可用”错误的解决方案。
适用范围:Microsoft Dynamics CRM Online
原始 KB 编号: 4338690
症状
在 Microsoft Dynamics 365 App for Outlook 中打开电子邮件时,会看到以下错误:
“视图不可用。 请与系统管理员联系。”
原因
如果停用了 Microsoft Dynamics 365 App for Outlook 使用的视图之一,则可能会出现此错误。 Microsoft Dynamics 365 App for Outlook 使用特殊窗体显示 Outlook 潜在顾客 (应用快速视图) 或联系人 (Outlook 联系人快速视图) 信息。 其中每个窗体都包含引用特定视图的列表。 如果其中一个视图已停用,你可能会看到 视图不可用 错误。
解决方案
确保未停用 Outlook 应用潜在客户快速视图窗体和 Outlook 应用联系人快速视图窗体使用的视图。 在 Microsoft Dynamics 365 App for Outlook 中查看电子邮件时,所使用的表单取决于电子邮件是来自潜在顾客还是联系人。 如果仅在电子邮件来自联系人时看到此错误,则可能只需要修复联系人表单使用的视图。 如果仅在电子邮件来自潜在顾客时看到错误,则可能只需要修复潜在顾客表单使用的视图。 在下面的示例中,我们将验证 Outlook 应用联系人快速视图窗体使用的默认视图是否已激活。 对于“潜在顾客”实体而不是“联系人”实体下找到的 Outlook 潜在顾客快速视图窗体,可以使用类似的步骤:
- 作为具有系统管理员或系统定制员安全角色的用户,请打开 Microsoft Dynamics 365 Web 应用程序。
- 导航到 “设置” ,然后选择“ 自定义项”。
- 选择 “自定义系统”。 这将打开 “默认解决方案 ”对话框。
- 依次选择“ 实体”、“ 联系人”和“ 窗体”。
- 打开 “Outlook 应用联系人快速视图 ”窗体。 默认情况下,此表单包括两个活动列表、一个机会列表和一个案例列表。 下表显示了列表的默认名称以及用于列表的默认视图。
- 可以使用这些表作为重新激活默认视图的引用。
- 在此示例中,我们将查看来自 Activity 实体的前两个列表。 可以对其他提到的实体重复相同的步骤。
- 切换回 “默认解决方案 ”对话框,选择“ 活动”,然后选择“ 视图”。
- 选择“ 视图 ”下拉列表,然后选择“ 非活动公共视图”。
- 验证“下一个活动”和“上一个活动”视图未显示在“非活动公共视图”列表中。 如果这些视图中的任何一个已停用,请选择它们,然后选择“ 激活”。
- 使用相同的步骤验证其他视图是否处于活动状态后,选择“ 发布所有自定义项”。
- 可能需要关闭并重新打开 Outlook,并可能清除浏览器缓存。
适用于 Outlook 联系人的应用快速视图
列表名称 | 默认视图 | Entity |
---|---|---|
下一个活动 | 下一个活动 | 活动 |
上次活动 | 上次活动 | 活动 |
最近的机会 | 以交互为中心的表单的最近机会 | 机会 |
最近发生的案例 | 我的活动案例 | 情况 |
Outlook 潜在顾客快速查看应用程序窗体
列表名称 | 默认视图 | Entity |
---|---|---|
下一个活动 | 下一个活动 | 活动 |
上次活动 | 上次活动 | 活动 |
利益 相关 者 | 所有利益干系人 | Connection |
竞争 对手 | 所有竞争对手 (摘要) | 竞争 对手 |
注意
如果要更改这些窗体使用的视图,而不是激活默认视图,可以打开窗体上列表节的属性来更改所选视图。 如果已停用其中一个默认视图,则即使列表当前仍在引用该默认视图,你实际上也无法看到它被列表引用。 相反,它将显示一些其他处于活动状态的视图名称。 可能需要先将其更改为另一个视图,然后将其更改为希望为更改生效而选择的视图。
Microsoft 已意识到在尝试更改视图时可能会遇到错误的问题。 可以更改“下一个活动”和“上次活动视图”,但在尝试更改其他视图时,遇到错误 (发生错误。请返回到主页,) 重试 。 Microsoft 正在调查此问题的保护解决方案。