在 Microsoft Dynamics 365 中导入解决方案时,导入文件太大,无法上传错误

本文提供了在 Microsoft Dynamics 365 中尝试导入解决方案时发生的错误的解决方案。

适用于: Microsoft Dynamics 365
原始 KB 数: 4462491

现象

尝试在 Dynamics 365 中导入解决方案时,导入会失败,并看到以下消息:

“导入文件太大,无法上传。
错误代码80040375”

原因

尽管错误消息指示要导入的解决方案的最大大小有问题,但另一个问题(例如 SQL 错误)可能是原因。

解决方法

选择“下载日志文件”按钮以查看更详细的消息。 你可能会看到详细信息,如以下消息:

导入失败。 有关详细信息,请参阅相关的错误消息。 :每个表中的 System.Data.SqlClient.SqlException (0x80131904) 列名必须是唯一的。 多次指定表“entity/table name”中的列名“<<column> name>”。

上面的示例消息是尝试导入该实体中已存在的字段时可能发生的 SQL 错误。

示例:如果在组织中创建了一个自定义字段,该字段在帐户实体上名为new_field1架构名称。 现在,你正在尝试导入一个解决方案,该解决方案包含帐户实体上具有相同架构名称的字段。 SQL 不允许同一表中具有相同名称的多个列,因此会导致导入失败。 你可能会发现,在目标环境中,已有一个具有相同架构名称但大小写不同的字段,例如new_Field1和要导入的解决方案中的字段new_field1。 如果目标环境中不需要具有相同名称的字段,请将其删除,然后重试导入。

如果错误仍然存在,并且无法使用日志文件中的详细信息解决问题,请联系Microsoft 支持部门寻求帮助。 还可以使用日志文件中的信息来搜索 Dynamics 365 社区的潜在解决方案。