无法删除包含已启用 SLA 的实体的托管解决方案

本文提供了一个解决方法,说明无法删除托管解决方案,该解决方案由 Dynamics 365 客户服务中启用了服务级别协议的实体(SLA)组成。

现象

无法删除包含启用了 SLA 的实体的托管解决方案。 此实体已作为以前导入的解决方案的一部分创建。

原因

在实体上启用后,无法禁用 SLA。

使用此示例了解此问题:

  1. Org1 中创建新解决方案并将其命名为 Field solution
  2. Field solution 中创建新实体并将其命名为 Field work
  3. Field solution 导出为托管解决方案。
  4. Field solution 导入到名为 Org2 的新组织中。

下一步:

  1. Org1 中创建另一个解决方案并将其命名为 Delta Field solution
  2. 将实体 Field workDelta Field solution 关联。 对实体启用 SLA。
  3. Delta Field solution 导出为托管解决方案。
  4. Delta Field solution 导入到 Org2

现在,如果尝试从 Org2 中删除 Delta Field 解决方案 ,则无法将其删除,因为它具有 与启用了 SLA 的字段工作实体关联的字段工作 实体。

解决方法

若要删除包含启用了 SLA 的实体的托管解决方案,您需要首先删除创建实体条目的之前导入的托管解决方案。 此操作可确保删除实体条目。 然后,您可以重新创建实体或重新导入托管解决方案。

若要删除 Org2 中的 Delta Field 解决方案,请先删除字段解决方案

可以删除字段解决方案 ,因为与其关联的实体(字段工作)未启用 SLA。 删除 字段解决方案 可确保删除 SLA 配置和实体。

注意

此解决方法不适用于现成实体,因为无法删除具有现成实体的现成实体或托管解决方案。