卡付款因卡类型不受支持而失败
本文有助于解决在 Microsoft Dynamics 365 Commerce 中处理信用卡或借记卡交易时出现的“卡类型不是接受的付款形式”错误。
现象
卡(或礼品卡)付款失败,销售点(POS)中出现以下错误消息:
卡类型不是接受的付款方式。 使用其他支付卡,然后重试。
还可以在事件日志中看到以下错误消息:
找不到 ID 为“Unknown”的卡片类型。
注意
在收到错误消息之前,卡付款已成功 获得 授权。 出现错误消息后,付款服务将取消卡付款。
原因
为通道的付款方式配置的卡类型与付款连接器返回的付款信息不匹配。
卡类型由箱范围、卡类型 ID(例如 信用卡 或 借记卡)和输入类型(Swipe
或 Manual
)的组合进行匹配。
解决方法 1
若要解决此问题,请确保为招标类型和通道正确配置卡片类型。
检查 POS 上的事件日志或Microsoft Dynamics Lifecycle Services (LCS) 中的 POS 客户端日志,了解正在使用哪些卡片类型值。
posPaymentCardTypeFilterByBinRangeIsDebitOrCredit
此事件指示付款处理器是否收到信用卡、借记卡或礼品卡类型的卡。 如果该值不符合预期,则可能不会正确设置或发送资金来源。
posPaymentCardTypeFilterByBinRangeIsSwipe
此事件指示用户是选择轻扫还是手动通过 POS 输入卡片。 如果具有匹配箱范围的卡片类型不允许手动输入,但该卡是通过轻扫条目输入的,则这可能会导致没有匹配的卡片类型。
注意
POS 根据付款处理器或连接器返回的卡类型查找匹配的箱范围。
- 如果卡类型为“信用卡”,POS 将查找为商店设置为“国际信用卡”的所有卡类型,并在这些卡类型中查找箱范围匹配。
- 如果卡类型为“借记卡”,POS 将查找为商店设置为“国际借记卡”的所有卡类型,并在这些箱范围内匹配。
- 如果付款连接器未设置卡类型,则 POS 默认将其视为信用卡,并在“国际信用卡”类型中查找匹配项。
在商务总部中,导航到零售和商务>渠道设置>付款方式>卡类型。
- 检查卡片品牌是否存在。 如果缺少卡片品牌,请添加卡片品牌。
- 检查卡类型(国际信用卡 或 国际借记卡)是否已正确分配给品牌。
- 在 工具栏中选择卡片编号 ,并确保将箱范围设置为覆盖未接受的卡号。
注意
如果信用卡或借记卡已正确设置,但仍收到错误,则错误可能是由返回错误卡类型 ID 的付款连接器引起的。 例如,付款连接器返回“借记卡”类型,但仅在商务总部中设置“信用卡”类型。 在这种情况下,请为信用卡和借记卡创建具有相同箱范围的卡类型。
在商务总部中,导航到有问题的频道或商店窗体。
- 选择“设置>付款方式”,然后选择卡使用的付款方式。
- 选择 电子付款设置 ,并将信用卡和借记卡类型添加到付款方式。
如果对卡类型或付款方式进行任何更改,请运行 CDX 1090 作业,并验证其状态是否显示为 已应用。
解决方法 2
若要解决此问题,请检查 Adyen 中设置的fundingSource
标识符。
在适用于 Adyen 的 Dynamics 365 付款连接器中,根据 fundingSource
Adyen 授权响应中的标识符设置卡类型。 fundingSource
如果 Adyen 未在授权响应中设置标识符,则不会在连接器中设置卡片类型。 但是,POS 在查找箱范围时默认为“信用额度”。
如果出现“缺少箱范围”问题,但最近未更改卡类型 bin 范围设置,则此问题可能是由以下原因之一引起的:
- 最近的 Adyen 固件升级已开始发送
fundingSource
标识符。 fundingSource
最近已在 Adyen 门户中启用该标识符。- 未为该特定卡或卡类型设置箱范围。
在 Adyen 固件版本 1.42.4 及更早版本中, fundingSource
标识符不是必需的,Adyen 不用于发送标识符。 在 Adyen 固件版本 1.44 及更高版本中,资金来源将作为 POS 终端的必需字段发送回授权响应中,该属性不受 Adyen 门户中的任何配置控制。
按照以下步骤在 Adyen 门户中打开或关闭“资金来源 ”:
- 登录 Adyen 门户。
- 在顶部导航栏上,选择“帐户>API URL>其他数据设置”。
- 向下滚动以查找 “资金来源 ”设置,启用或禁用它,然后保存更改。
详细信息
有关详细信息,请参阅 付款方式设置。
第三方信息免责声明
本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。