Z 报表的数据对帐问题

错误代码:SYS103633

本文提供有关Microsoft Dynamics 365 Commerce 总部中 Z 报表数据对帐问题的解决方案。

现象

  • Z 报告中显示的金额与计算报表中显示的总计不匹配。
  • Headquarters 中的交易的行项数量不正确,或者行总计与交易总计不匹配。
  • Headquarters 班次中显示的交易数量小于 Z 报表上的交易数量。
  • 由于上述原因之一,语句发布失败。

原因

前面描述的症状的最常见根本原因是在渠道数据库中生成了重复的交易 ID。 由于以下原因,可能会生成重复的交易 ID:

  • 现代销售点 (MPOS) 的本地数据库存储已损坏。
  • MPOS 在脱机模式下有一些交易,并且使用无法访问脱机数据库的帐户重新激活。
  • 与交易 ID 的生成相关的自定义存在问题。

解决方法

通常,Commerce 依靠数字序列来生成序列交易 ID。 如果系统无法确定是否出于任何原因使用了数字序列,则会生成重复的事务 ID。

要解决重复交易 ID 问题,请创建一个支持票证以检查是否可以修复交易数据。 在某些情况下,例如当 Headquarters 中没有数据丢失时,就不可能或不需要修复数据。

为帮助防止将来出现此问题,您必须在 Headquarters 中启用启用新交易 ID 以避免交易 ID 重复功能。 Microsoft Dynamics 365 Commerce 版本 10.0.19 中引入了此功能。 它通过确保为每个交易创建唯一的交易 ID 来帮助防止创建序列交易 ID。 有关此功能的详细信息,请参阅防止重复的交易 ID