Business Central 云迁移中的“无法连接到 SQL 数据库,ErrorCode=SqlFailedToConnect”错误
本文解决了尝试连接到 Business Central 云迁移中的 SQL 数据库时出现的“无法连接到 SQL 数据库,ErrorCode=SqlFailedToConnect”错误消息。
现象
尝试连接到 Business Central 云迁移中的 SQL 数据库时,会收到以下错误消息:
无法连接到 SQL 数据库 ErrorCode=SqlFailedToConnect。
此错误消息通常与以下错误消息一起发生:
检查链接服务配置是否正确,并确保SQL 数据库防火墙允许集成运行时访问。
原因
错误消息可能有多种原因。 最常见的原因是在长错误消息中返回,例如:
用户帐户的问题:
用户登录失败...
必须更改该帐户的密码。
帐户已禁用。
SQL Server 未运行,或禁用对 SQL Server 的远程访问:
找不到或无法访问服务器。 请验证实例名称是否正确,SQL Server 是否已配置为允许远程连接。
解决方法
若要解决此问题,请在 Integration Runtime 主机上运行以下 Windows PowerShell 命令。 如果 Integration Runtime 主机无法连接,它将返回描述性错误。
sqlcmd –S "{SQL Server Name}" -d "{Database Name}" -U "{SQL Server Authenticated User Name}" -P "{PlaceholderSQLServerAuthenticatedPassword}" -Q 'select * from [dbo].[Intelligent Cloud]'
若要允许 Integration Runtime 客户端 IP 地址访问 SQL Server,请在本地 master 数据库上运行以下命令:
sp_set_firewall_rule
若要允许远程访问 SQL Server,请运行以下命令:
run sp_configure 'remote access', 1;