Business Central 云迁移中的活动超时
本文提供有关在 Business Central 云迁移期间活动超时的问题的故障排除步骤。
现象
在 Business Central 云迁移期间,活动超时。
原因
如果在云迁移设置期间活动超时,则可能是因为 Integration Runtime 无法与 SQL Server 建立连接,或者由于大型本地数据库中的索引碎片整理。 如果在迁移运行期间超时,原因很可能是本地 SQL Server 疲弱或繁忙。
解决方法
如果 SQL 连接永久断开,请检查 .NET 4.72 或更高版本是否在集成运行时的主机上运行。
在Azure 数据工厂页上检查其他 Integration Runtime 要求。
对于数据库性能问题,建议在设置云迁移之前更新统计信息并重新组织本地数据库中的索引。
若要更新统计信息,请运行以下查询(例如,Microsoft连接到本地数据库的 SQL Management Studio 中):
EXEC sp_updatestats;
若要重新组织索引,请执行以下查询:
EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'