即使已启用Microsoft 365 访问,也会出现权限错误
本文介绍如何解决用户在尝试从 Microsoft Teams 访问 Business Central 记录时可能遇到的权限相关问题,尽管在 Business Central 管理中心中正确启用了具有 Microsoft 365 许可证的访问。
现象
当用户在 Microsoft Teams 对话中选择 Business Central 记录的链接或卡片时,他们会收到类似于“抱歉,当前权限阻止了操作”的错误消息。
原因
此为有意行为。 管理员必须先配置可在 Microsoft Teams 中访问哪些数据。 如果管理员在 Business Central 管理中心启用访问权限,但不在“许可证配置”页上分配权限,则尝试访问 Microsoft Teams 中的 Business Central 记录的用户将预配其用户记录,而无权访问任何对象。
解决方案
注意
若要解决此问题,需要在 Business Central 中拥有租户管理员权限。
除了在 Dynamics 365 Business Central 管理中心启用 Microsoft 365 访问之外,还可以在 “许可证配置 ”页上分配权限。 但是,在 “许可证配置 ”页上分配的权限仅适用于新创建的用户。 对于已创建的用户,还必须通过 “用户列表 ”页分配缺少的权限。