客户端 IP 地址无法访问 API 服务器

本文介绍如何解决无法连接到 Azure Kubernetes 服务 (AKS) 群集时发生的问题,因为客户端 IP 地址无法访问 AKS API 服务器。

先决条件

现象

尝试从Azure 门户访问 Kubernetes 资源(如 mamespaces 和工作负载)时,可能会遇到以下错误:

网络错误

无法访问 API 服务器“https://< API-server-FQDN>”或 API 服务器太忙,无法响应。 检查网络设置并刷新以重试。

AKS 资源中 mamespaces 的屏幕截图。

原因

API 服务器授权的 IP 范围 可能已在群集的 API 服务器上启用,但 IP 范围中不包括客户端的 IP 地址。 若要检查此功能是否已启用,请参阅 Azure CLI 中的以下 az aks show 命令是否生成 IP 范围列表:

az aks show --resource-group <cluster-resource-group> \
    --name <cluster-name> \
    --query apiServerAccessProfile.authorizedIpRanges

解决方案

查看群集的 API 服务器授权范围,并在该范围内添加客户端的 IP 地址。

注意

  1. 是否从通过代理服务器或防火墙路由流量的公司网络访问 API 服务器? 然后在将客户端 IP 地址添加到 API 服务器的授权范围列表中之前,请向网络管理员请求。

  2. 此外,在添加客户端 IP 地址之前,请向群集管理员询问,因为可能会担心向授权范围列表添加临时 IP 地址。

  1. 从Azure 门户导航到群集。

  2. 在左侧菜单中,找到 “设置” ,然后选择“ 网络”。

  3. “网络 ”页上,选择“ 概述 ”选项卡。

  4. 在“资源设置”下选择“管理”。

  5. “授权 IP 范围 ”窗格中,添加客户端 IP 地址,如以下屏幕截图所示:

    授权 IP 范围窗格的屏幕截图。

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