错误AADSTS70001 - 在目录中找不到具有标识符的应用程序

本文介绍了以下问题:尝试登录到已与 Microsoft Entra ID 集成的基于 SAML 的单一登录 (SSO) 配置的应用时,会收到错误消息“AADSTS70001错误 - 在目录中找不到标识符的应用程序”。

症状

尝试登录到已设置为使用 Microsoft Entra ID 使用基于 SAML 的 SSO 进行标识管理的应用程序时收到错误AADSTS70001

原因

Issuer从应用程序发送到 SAML 请求中的Microsoft Entra ID的属性与 Microsoft Entra ID 中为应用程序配置的 Identifier 值不匹配。

解决方案

确保 Issuer SAML 请求中的属性与 Microsoft Entra ID 中配置的 Identifier 值匹配。

在“基于 SAML 的 SSO 配置”页上的“ 基本 SAML 配置 ”部分中,验证“标识符”文本框中的值是否与错误中显示的标识符值的值匹配。 如果 URL 末尾有尾部斜杠,则还应包含该斜杠。

在Microsoft Entra 管理中心中使用测试 SSO 函数

Microsoft Entra 管理中心可帮助排查 SAML 配置错误。

Microsoft Entra 管理中心中测试 SSO 功能的屏幕截图。

  1. 在Microsoft Entra 管理中心中,转到“企业应用程序”,并单击需要故障排除的应用程序。
  2. 使用左侧导航菜单导航到 “单一登录 ”页
  3. 单击“ 测试此应用程序 ”以使用“测试 SSO”功能。
  4. 将收到的错误复制并粘贴到“解决错误”部分,然后单击“获取解决指南
  5. 查看找到的颁发者与标识符之间的差异。
  6. 更正颁发者或标识符。

更多信息

有关 Active Directory 身份验证和授权错误代码的完整列表,请参阅Microsoft Entra身份验证和授权错误代码

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