虚拟机上的“FSLogix_unsupported_environment”和OneDrive 同步错误

症状

在使用 FSLogix 配置的虚拟机上,OneDrive 同步客户端无法同步,并且你会收到以下错误消息:

OneDrive 无法同步
请与系统管理员联系以获取帮助。
错误代码:FSLogix_unsupported_environment

此外,OneDrive 同步客户端在关闭错误消息窗口后关闭。

原因

出现此问题的原因是,在使用 FSLogix 2009 修补程序 1 之前的 FSLogix 版本的虚拟机上阻止了 OneDrive 同步 客户端。 Microsoft 不再支持这些早期版本。

解决方案

若要解决此问题,请在使用 OneDrive 同步 客户端的所有虚拟机上下载并安装最新版本的 FSLogix

更多信息

管理员可以使用以下方法之一在其环境中运行的虚拟机上检查 FSLogix 的版本。

检查多个虚拟机上的 FSLogix 版本

注意: 以下 PowerShell 脚本按原样提供,Microsoft 不支持。

使用 FSLogix 版本验证 脚本。

检查一个虚拟机上的 FSLogix 版本

  • 使用 FSLogix FRX 命令行工具:

    C:\Program Files\FSLogix\Apps\frx.exe version
    
  • 运行以下 PowerShell 命令以获取 InstallVersion FSLogix 注册表项的 属性:

    (Get-ItemProperty -Path HKLM:\SOFTWARE\FSLogix\Apps).InstallVersion
    
  • 运行以下 PowerShell 命令以获取系统上安装的 Microsoft FSLogix 应用版本:

    $uninstallPath = "HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall"
    $appCheck = Get-ItemProperty -Path $uninstallPath\* | Where-Object { $_.DisplayName -eq "Microsoft FSLogix Apps" }
    ($appCheck | Where-Object {$_.EstimatedSize -eq ($appCheck | Measure-Object -Maximum EstimatedSize).Maximum}).DisplayVersion