使用代理自动配置文件时 Outlook 2016 for Mac 崩溃

现象

假设出现了下面这种情景:

  • 在配置为使用代理自动配置(PAC)文件的 Mac 计算机上使用 Microsoft Outlook 2016 for Mac。
  • 尝试使用 HTTP 协议访问远程资源。

在此方案中,Outlook 2016 for Mac 崩溃。

原因

当 Mac 操作系统中的 自动代理配置 设置中使用基于文件的 PAC 文件时,会出现此问题。

注意

基于文件的 PAC 文件是 URL 以 file:// 开头的文件。

解决方法

若要解决此问题,请在可以使用 HTTP 协议访问的 Web 服务器上托管 PAC 文件,然后在 Mac 操作系统中高级网络首选项的自动代理配置设置中指定文件的 URL。

若要在 Mac 操作系统中编辑自动代理配置设置,请执行以下步骤:

  1. 打开“系统首选项”
  2. 选择“网络”。
  3. 选择“高级”。
  4. 选择“代理”选项卡。
  5. 在“选择要配置的协议”下,选择“自动代理配置”。
  6. 输入托管 PAC 文件的 URL。

详细信息

  • 与支持人员交谈

    若要报告问题或提供反馈,请转到 Outlook for Mac 中的帮助>联系支持人员。

  • 询问社区

    从 Microsoft 365 和 Office 中的专家那里获取帮助。

第三方信息免责声明

本文中提到的第三方产品由 Microsoft 以外的其他公司提供。 Microsoft 不对这些产品的性能或可靠性提供任何明示或暗示性担保。

Microsoft 会提供第三方联系信息来帮助你查找技术支持。 此联系信息可能会更改,恕不另行通知。 Microsoft 不保证此第三方联系信息的准确性。

本文档中的信息和解决方案表示截至发布日期Microsoft公司的当前视图。 此解决方案可通过Microsoft或通过第三方提供商获得。 Microsoft不特别推荐本文可能介绍的任何第三方提供商或第三方解决方案。 本文可能还有其他第三方提供商或第三方解决方案未介绍。 由于Microsoft必须响应不断变化的市场状况,因此不应将此信息解释为Microsoft的承诺。 Microsoft无法保证或认可由Microsoft或任何提及的第三方提供商提供的任何信息或任何解决方案的准确性。

Microsoft不作任何保证,不包括所有表示、担保和条件,无论是明示、默示还是法定条件。 这些内容包括但不限于有关任何服务、解决方案、产品或任何其他材料或信息的陈述、担保或标题条件、不侵权、令人满意的条件、适销性和适用性。 在任何情况下,Microsoft对本文提及的任何第三方解决方案都负责。