影响出站直接路由调用的问题
使用直接路由从 Microsoft Teams 客户端到会话边界控制器 (SBC) 进行出站调用时,可能会遇到各种问题。 这些问题包括:
- 向呼叫接收方显示错误的呼叫方 ID。
- 未建立与 SBC 的连接。
- 租户中的某些用户无法进行调用。
- 租户中的用户都无法进行调用。
本文讨论这些问题的潜在原因,并提供可以尝试的解决方案。
向收件人显示的来电显示错误
使用直接路由时,会话初始协议 (SIP) 选项消息中的 和 P-Asserted-Identity
标头中列出了From
传递给呼叫接收者的呼叫方 ID 信息。
标头 From
包含以下任何项:
- 分配给发起呼叫的呼叫者的电话号码。 如果呼叫方的电话号码必须对呼叫接收方隐藏,则会将其替换为“匿名”。
- 使用
CsCallingLineIdentity
cmdlet 分配给调用方的服务编号。 - 转接呼叫时原始呼叫者的电话号码。
标头 P-Asserted-Identity
包含为呼叫计费的用户的电话号码。 如果 Privacy:id
设置了 ,则表示标头中的信息必须对呼叫接收方隐藏。
原因
如果 和 标头中From
的信息不匹配,并且公用电话交换网络 (PSTN) 将标头信息优先P-Asserted-Identity
于From
标头信息,则显示不正确的P-Asserted-Identity
信息。
解决方案
若要确保向呼叫接收方显示正确的呼叫方 ID,请将 SBC 配置为从 SIP 选项消息中删除 P-Asserted-Identity
标头或修改其内容。
未建立与 SBC 的连接
有时,调用到达 SBC,但未建立连接。 在这种情况下,当 SBC 收到来自 Teams 的 SIP 选项消息时,它将返回一条失败消息,其中包含 400 到 699 范围内的错误代码。
以下任一原因都可能会阻止与 SBC 的连接。
原因 1
SIP 失败消息由与 SBC 位于同一网络上的另一个电话设备生成。
解决方法 1
对其他设备进行故障排除以修复错误。 如果需要帮助,请联系设备供应商。
原因 2
PSTN 提供商遇到了一些问题,并且正在发送 SIP 失败消息。 如果失败错误代码为 SIP 403 或 SIP 404,则很可能是这种情况。
解决方法 2
请联系 PSTN 提供商获取支持以解决此问题。
原因 3
此问题不是由网络上的另一台设备或 PSTN 提供商引起的。 但是,原因在其他方面是未知的。
解决方法 3
请联系 SBC 供应商以获取支持以解决此问题。
某些用户无法进行呼叫
如果 Teams 客户端与 SBC 之间的连接正常工作,但某些用户无法进行调用,则问题可能是由这些用户设置不正确或预配不当引起的。
原因 1
用户在 Teams 中的“ 呼叫 ”选项卡上缺少拨号盘。
解决方法 1
确保用户具有正确的许可证 (E3 和电话系统或 E5) 以及所有必需的设置。 若要检查设置,请在 Teams PowerShell 中运行 Get-CsOnlineUser cmdlet,如下所示:
Get-CsOnlineUser -Identity <UserIdParameter> | fl Identity,EnterpriseVoiceEnabled,HostedVoiceMail,OnPremLineURI
必须按照 为用户启用直接路由、语音和语音邮件中所述指定所有必需的值。
原因 2
联机语音路由策略中没有任何模式 (OVRP) 与用户拨打的号码匹配。
解决方法 2
请确保满足以下条件:
- OVRP 中有一个与拨号号码匹配的模式。
- 调用的使用情况配置文件与为特定用户设置的配置文件匹配。
- 为 SBC 指定的网关已启用。 如果已禁用,请启用它或选择启用的其他网关。
原因 3
用户的 OVRP 包含无效字符。
解决方法 3
从 Microsoft Word 或其他 WYSIWYG 编辑器中粘贴信息时,可以在 OVRP 中插入无效的不可见字符。 虽然不会显示这些字符,但在决定调用应采用的路线时,会考虑这些字符。
若要解决此问题,请删除该策略,然后通过手动重写策略或从非 WYSIWYG 编辑器(如记事本)复制它来重新创建它。
没有用户能够进行呼叫
如果任何用户都无法进行呼叫,则呼叫可能无法到达 SBC。 检查以下原因之一。
原因 1
Teams 具有禁用的网关。
解决方法 1
使用 Microsoft Teams 管理中心确保 Teams 使用的网关可用且已启用。
还可以根据需要使用 Teams PowerShell 检查和更新网关。
若要检查网关的状态,请运行 Get-CsOnlinePSTNGateway cmdlet。 输出必须显示 参数的值 Enabled
设置为 True
。 在以下示例中, Enabled
将 网关的 参数设置为 True
sbc1.contoso.com
,但对于网关则不设置为 sbc2.contoso.com
。
Get-CsOnlinePSTNGateway | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
若要确保 sbc2.contoso.com
网关可供 Teams 使用,请运行 Set-CsOnlinePSTNGateway cmdlet 将 Enabled
参数设置为 True
。
Set-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" -Enabled $true
若要检查网关现在是否sbc2.contoso.com
可用,请再次运行 Get-CsOnlinePSTNGateway
cmdlet:
Get-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
有关详细信息,请参阅 将 SBC 连接到直接路由。
原因 2
网关未响应 SIP 选项消息,因为网络上的某些设备(如防火墙)正在阻止这些消息。
解决方法 2
确保在将 SBC 连接到 Internet 的所有网络设备上都允许 SIP 信号 IP 和 FQDN。 必须允许的 IP 地址在 SIP 信令:FQDN 中列出。
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