Windows Defender 或终结点保护客户端疑难解答

适用于: Configuration Manager(current branch)

如果遇到Windows Defender或 Endpoint Protection 问题,请使用本文排查以下问题:

更新Windows Defender或 Endpoint Protection

症状

Windows Defender或 Endpoint Protection 自动与 Microsoft 更新配合使用,以确保病毒和间谍软件定义保持最新。

本部分介绍自动更新的常见问题,包括以下情况:

  • 会看到指示更新失败的错误消息。

  • 检查更新时,会收到一条错误消息,指出无法检查、下载或安装病毒和间谍软件定义更新。

  • 即使设备已连接到 Internet,更新也会失败。

  • 汇报不会按计划自动安装。

原因

更新问题的最常见原因是 Internet 连接问题。 如果你知道你的设备已连接到 Internet,因为你可以浏览到其他网站,则问题可能是由与 Windows 中的 Internet 设置冲突引起的。

要解析的选项

步骤 1:重置 Internet 设置

  1. 退出所有打开的程序,包括 Web 浏览器。

    注意

    重置这些 Internet 设置时,可能会删除浏览器临时文件、Cookie、浏览历史记录和联机密码。 它不会删除你的收藏夹。

  2. 转到“ 开始 ”菜单,然后打开 inetcpl.cpl

  3. 切换到“ 高级 ”选项卡。

  4. “重置 Internet Explorer 设置”部分中,选择“ 重置”,然后再次选择“ 重置 ”以确认。

  5. 重置设置时,选择 “确定 ”。

  6. 再次尝试更新Windows Defender。

如果问题仍然存在,请继续执行下一步。

步骤 2:确保在计算机上正确设置日期和时间

如果错误消息包含代码0x80072f8f,则问题很可能是由计算机上不正确的日期或时间设置引起的。 转到“开始”菜单,依次选择“设置”、“时间 & 语言”和“日期 & 时间”。

步骤 3:重命名计算机上的软件分发文件夹

  1. 停止Windows 更新服务。

    1. 转到 “开始”,然后打开 services.msc

    2. 选择Windows 更新服务。 转到 “操作 ”菜单,然后选择“ 停止”。

  2. 重命名 SoftwareDistribution 目录。

    1. 以管理员身份打开命令提示符。

    2. 输入以下命令:

      cd %windir%
      ren SoftwareDistribution SDTemp
      exit
      
  3. 重启Windows 更新服务。

    1. 切换回 “服务 ”窗口。

    2. 选择Windows 更新服务。 转到“ 操作 ”菜单,然后选择“ 启动”。

    3. 关闭“服务”窗口。

步骤 4:在计算机上重置 Microsoft 防病毒更新引擎

  1. 以管理员身份打开命令提示符。

  2. 输入以下命令:

    cd \
    
    cd program files\windows defender
    
    MpCmdRun -RemoveDefinitions -all
    
    exit
    
  3. 重启计算机。

  4. 再次尝试更新Windows Defender。

如果问题仍然存在,请继续执行下一步。

步骤 5:手动安装定义更新

手动下载最新更新

步骤 6:联系 Microsoft 支持人员

如果这些步骤未解决问题,请联系 Microsoft 支持部门。 有关详细信息,请参阅 支持选项和社区资源

启动Windows Defender或 Endpoint Protection 服务

症状

你会收到一条消息,通知你Windows Defender或 Endpoint Protection 未监视计算机,因为该程序的服务已停止。应立即重启它。

解决方案

步骤 1:重启计算机

关闭所有应用程序并重新启动计算机。

步骤 2:检查 Windows 服务

  1. 转到 “开始”,然后打开 services.msc

  2. 选择Windows Defender防病毒服务

  3. 确保 “启动类型” 设置为 “自动”。

  4. 转到 “操作 ”菜单,然后选择“ 启动”。

    1. 如果此操作不可用,请选择“ 停止”。 等待服务停止,然后选择“ 启动” 操作以重启服务。

请注意在此过程中可能出现的任何错误。 请联系Microsoft 支持部门并提供错误信息。

步骤 3:删除任何第三方安全程序

注意

某些安全应用程序不会完全卸载。 可能需要为以前的安全应用程序下载并运行清理实用工具,以完全删除它。

  1. 转到 “开始”并 打开 appwiz.cpl

  2. 在已安装的程序列表中,卸载任何第三方安全程序。

  3. Restart your computer.

警告

删除安全程序时,计算机可能不受保护。 如果在删除现有安全程序后安装 Windows Defender 时遇到问题,请联系 Microsoft 支持部门。 选择“安全”产品系列,然后选择Windows Defender产品。

Internet 连接问题

若要使计算机从Windows 更新接收最新更新,请将其连接到 Internet。

  1. 转到 “开始”并 打开 ncpa.cpl

  2. 打开连接名称以查看连接 状态

  3. 如果计算机已连接, 则 IPv4 连接 和/或 IPv6 连接 状态为 Internet

  4. 如果计算机未连接,请选择连接名称,然后选择“ 诊断此连接”。

关闭任何打开的程序并重新启动计算机。

检测到的威胁无法修正

当Windows Defender或 Endpoint Protection 检测到潜在威胁时,它会尝试通过隔离或删除威胁来缓解威胁。 这些威胁可能隐藏在压缩存档 (.zip) 或网络共享中。

删除或扫描文件

  • 如果检测到的威胁位于压缩的存档文件中,请浏览到该文件。 删除文件,或手动扫描它。 右键单击该文件,然后选择“使用Windows Defender扫描”。 如果Windows Defender检测到文件中的其他威胁,它会通知你。 然后,可以选择适当的操作。

  • 如果检测到的威胁位于网络共享中,请打开该共享并手动扫描它。 右键单击该文件,然后选择“使用Windows Defender扫描”。 如果Windows Defender检测到网络共享中的其他威胁,它会通知你。 然后,可以选择适当的操作。

  • 如果不确定文件的来源,请在计算机上运行完全扫描。 完全扫描可能需要一些时间才能完成。

另请参阅

Endpoint Protection 客户端常见问题解答

终结点保护客户端帮助