Outlook 无法通过为 Microsoft 365 中的 Exchange Online 邮箱使用 Exchange 自动发现来设置新的配置文件

现象

尝试使用 Microsoft Outlook 中的“添加新帐户”向导为 Microsoft 365 设置新的邮件帐户时,Outlook 配置文件无法自动设置。 此外,当 Outlook 尝试为您的配置文件设置服务器设置时,您收到以下错误消息:

到邮件服务的加密连接不可用

使用 Microsoft 远程连接分析器进行测试时,可能会返回以下错误消息:

自动发现无法处理给定的电子邮件地址。 仅允许邮箱和联系人。

原因

此问题是由下列原因之一导致的:

  • 在 Outlook 中的“添加新帐户”向导的“自动帐户设置”页中输入了错误的电子邮件地址。
  • 您正在运行的 Outlook 版本未安装自动连接 Exchange Online 所需的 Outlook 更新。
  • 域的自动发现 CNAME 记录不存在或未正确设置。
  • 在使用 Active Directory 同步的组织中,不会为本地 Active Directory中同步的用户正确设置邮件mailNicknamedisplayNameproxyAddresses 属性。

备注

本文讨论了 Outlook 2016、Outlook 2013 和 Exchange Online。 有关从移动设备连接到 Exchange Online 的帮助,请参阅 在手机或平板电脑上设置和使用 Microsoft 365。 有关将 Outlook 连接到第三方服务的帮助,请联系第三方邮件提供商。

解决方法

方法 1:运行 Microsoft 365 支持和恢复助手

备注

Microsoft 支持部门和恢复助手方案不适用于新的 Outlook for Windows。

“获取帮助”应用中使用经典 Outlook 配置文件设置疑难解答

此疑难解答执行自动检查,并返回可能的解决方案来修复任何检测到的问题。

其他方法

如果您使用的是自定义域

如果方法 1 无法解决问题,并且你在 Microsoft 365 中使用自定义域,请按照列出的顺序使用以下方法。 如果第一种方法不能解决问题,请继续使用下一种方法。

方法 2:升级到最新版本的 Outlook

首先,确保在 Outlook 中“添加新帐户”向导的“自动帐户设置”页中输入正确的电子邮件地址和密码。

如果使用的是 Outlook 2010 或更早版本,请升级到最新版本的 Outlook。 有关详细信息,请参阅在 PC 上使用 Microsoft 365 for business 下载并安装 Office

有关如何设置 Outlook for Microsoft 365 的详细信息,请参阅以下资源:

如果此方法不能解决问题,请转到方法 3。

方法 3:确保正确设置了 Autodiscove CNAME 记录

Autodiscover CNAME 记录必须存在并且正确设置。 强烈建议在使用 Outlook 连接到 Exchange Online 邮箱时设置 Exchange 自动发现。 若要在 Exhcange Online 中实现 Outlook 连接,需要设置自动发现及其他相关 DNS 记录。 管理员可以使用 Microsoft 365 中的域疑难解答向导或 Microsoft 远程连接分析器确认记录是否设置正确。

使用 Microsoft 365 中的域疑难解答向导

若要使用 Microsoft 365 中的域疑难解答向导,请执行以下步骤。

  1. 使用管理员帐户登录 Microsoft 365 门户 (https://portal.office.com)。
  2. 选择“管理员以打开Microsoft 365 管理中心。
  3. 在左侧导航窗格中,选择“域,然后选择受影响的用户使用的域名,然后选择“故障排除以启动向导。

使用 Microsoft 远程连接分析器

要使用远程连接分析器测试 Exchange 自动发现功能是否正常工作,请按照下列步骤操作:

  1. 在 Web 浏览器中,浏览到以下网址的 Microsoft 远程连接分析器工具:

    远程连接分析器 Outlook 自动发现测试

  2. 完成窗体上的所有必填字段,然后选择“ 执行测试”。

    Outlook 连接表单的屏幕截图,其中显示了电子邮件地址、身份验证类型和凭据的必填字段。

  3. 测试完成后,确认测试是否成功。

    • 如果测试成功,则表示自动发现可以正常工作。

    • 如果测试失败,请验证是否正确设置了自动发现服务。 有关更多信息,请参阅以下资源:

方法 4:确保 Active Directory 中的用户属性已正确设置

如果有 Exchange 混合部署,可以使用 Get-RemoteMailbox cmdlet 来确定是否为受影响的用户设置了正确的属性。 如果其中一个或多个属性的值未设置,则会出现常见问题。 以下示例显示为用户设置的正确属性。

属性 示例
primarySMTPAddress ted@contoso.com
别名 ted
displayName Ted Bremer
emailAddresses SMTP:ted@contoso.com X400:c=us;a= ;p=First Organization;o=Exchange;s=Bremer;g=Ted
remoteRoutingAddress ted@contoso.mail.onmicrosoft.com

若要更新这些属性,可以使用 Set-RemoteMailbox cmdlet。

为这些属性设置正确的值后, 强制执行目录同步,然后尝试在 Outlook 中设置用户的电子邮件帐户 。

如果不使用自定义域

方法 2:在 Outlook 中使用“添加新帐户”向导

如果方法 1 无法解决问题,并且未将自定义域与 Microsoft 365 一起使用,则可以使用 Outlook 中的“添加新帐户向导”通过注册 Microsoft 365 时为用户关联 Exchange Online 邮箱的默认“onmicrosoft.com”电子邮件地址来设置 Outlook 配置文件。 使用“添加新帐户向导”设置新的邮件配置文件时,以 user>@<domain.onmicrosoft.com>(例如,)kim@contoso.onmicrosoft.com的形式<指定Microsoft 365 密码和默认Microsoft 365 电子邮件地址。

此方法受支持,适用于可能不打算拥有自己的虚荣域或自定义域的客户。 此方法还支持自动发现。 如果你的邮箱服务器位置改变,Outlook 将使用邮箱服务器的新位置进行相应的更新。

详细信息

Microsoft 不支持在 Outlook 中手动设置配置文件,以连接到 Microsoft 365 的 Exchange Online 中的邮箱。 但是,我们可以帮助你完成其他任务,例如设置 DNS 和自动发现记录,如方法 2 中所述。 此方法允许你通过受支持的方法设置帐户。

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