将邮箱移到 Microsoft 365 后,用户看不到闲/忙信息

症状

将邮箱移到 Microsoft 365 后,本地用户在“日程安排助理”中无法查看邮箱的闲/忙信息。

屏幕截图显示了本地用户在“日程安排助理”中无法查看邮箱闲/忙信息。

此外,用户无法再查看“日历”文件夹,并且用户收到“无法更新”的错误。

屏幕截图显示了用户无法再查看“日历”文件夹并收到错误。

原因

“日历”文件夹的默认权限设置为参与者。 在跨林方案中使用“日程安排助理”查询闲/忙信息时,可用性服务使用组织关系而不是委派的用户权限。 “日程安排助理”代表组织关系而不是代表请求该关系的用户发出跨林请求。 组织关系链接到日历权限中显示的默认帐户。 因此,它无法处理明确授予的权限,例如“闲/忙时间”或“闲/忙、主题、位置”。

解决方法

当“日历”文件夹的默认权限设置为参与者时,只有通过将日历直接附加到 Outlook 的日历视图来使用用户委派时,才能获取详细信息。 在混合部署中,闲/忙和日历共享功能的工作方式与两个用户在同一环境中的工作方式不同。 默认权限确定远程林中的用户可以看到的闲/忙信息类型。 如果默认权限设置为参与者,则不会向远程用户显示闲/忙信息,并且用户无法查看邮箱日历。 这是因为这两种权限都不提供闲/忙可见性。

屏幕截图显示了默认权限级别设置为“参与者”,不提供任何闲/忙可见性。

屏幕截图显示了默认权限级别设置为“无”,不提供任何闲/忙可见性。

如果远程用户必须要查看邮箱的闲/忙信息,则邮箱所有者可以通过将默认权限更改为闲/忙时间闲/忙时间、主题、位置来解决此问题。 这会更改向所有远程用户共享的闲/忙信息。 例如,默认权限可以设置为闲/忙时间

将默认权限级别更改为闲/忙时间的屏幕截图。

远程用户可以在“日程安排助理”中查看闲/忙数据:

屏幕截图显示了远程用户可以在“日程安排助理”中查看闲/忙数据。

或者,远程用户可以附加日历的形式查看闲/忙数据:

屏幕截图显示了远程用户以附加日历的形式查看闲/忙数据。

可以向远程用户授予“日历”文件夹权限,以获取对“日历”文件夹内容的其他访问权限:

屏幕截图显示了用户权限设置为审阅者,可读取“完整详细信息”。

注意

在混合环境中,授予闲/忙时间、主题、位置(有限详细信息)权限是不够的。 必须至少向用户授予审阅者权限,才能查看日历项详细信息。

远程用户(测试用户 1)现在可以看到邮箱“日历”文件夹:

屏幕截图显示了邮箱“日历”文件夹。

更多信息

有关跨林闲/忙配置的更多信息,请单击下面的文章编号,以在 Microsoft 知识库中查看相应的文章:

3079932 在 Microsoft 365 远程林中,用户只能看到基本的闲/忙邮箱信息

设置默认日历权限或明确授予用户日历权限时,参与者权限存在一些差异。 设置默认日历权限时,闲/忙设置使用

屏幕截图显示了当默认日历权限级别设置为“参与者”时,闲/忙设置设置为“无”。

向用户被授予参与者权限时,权限级别将自动更改为自定义。 这包括闲/忙时间

屏幕截图显示,向用户授予参与者权限后,权限级别将自动更改为“自定义”,其中包括闲/忙时间。

这是预期的行为,因为可以在日历中创建项的用户也可以查看文件夹并查看闲/忙信息。