如果用户邮箱规则自动转发邮件,则传输规则不匹配
症状
创建 Exchange 传输规则来控制组织中用户自动转发的邮件的行为。 如果用户创建邮箱规则来自动转发邮件,则发送转发的邮件时传输规则不匹配。
原因
最近更改了用于评估自动转发邮件发件人的传输规则逻辑。 转发邮件的发件人地址现在是原始发件人,不再是转发者。
之所以对逻辑进行了此更改,是因为在某些情况下,Exchange 传输规则会将发件人地址与邮件信封而不是邮件头进行匹配。 此更改可确保始终正确应用传输规则匹配,无论发件人的地址是存储在邮件头还是邮件信封中。
解决方案
若要维护传输规则的行为,请将 邮件中的“匹配发件人地址” 设置从 “标头” 更改为 “标头”或“信封”:
在 Exchange 管理员中心,转到“邮件流>规则”。
双击列表中受影响的规则,然后在 邮件标题中找到“匹配发件人地址 ”。
在此标题下的列表中,选择 “标题”或“信封”。
注意
- 邮件流规则用于根据邮件类 (
IPM.note.forward
) 匹配自动转发邮件。 但是,如果转发是通过Outlook 网页版 (ForwardingSmtpAddress
) 设置的,或者由管理员对邮箱 (ForwardingAddress
) 的属性进行设置,则邮件类是正常的 (IPM.Note
) ,传输规则不会检测到它们。 有关自动转发的详细信息,请参阅 Exchange Online中有关自动电子邮件转发的注意事项。 - 此更改还会影响邮箱重定向规则,因为传输规则评估的发件人现在是原始发件人,而不是设置规则的邮箱。 若要维护此规则的行为,请基于收件人而不是发件人在传输规则中设置例外。 或者,将此规则更改为自动转发规则。
更多信息
仍然需要帮助? 请转到 Microsoft 社区。