BizTalk Server 工具问题疑难解答

本主题提供了一个集中位置,用于了解使用 BizTalk Server 附带的工具时遇到的常见问题。

已知问题

BizTalk Server 工具和实用程序在支持 UAC 的 Windows 系统上可能无法正确工作

问题

当BizTalk Server安装在支持用户帐户控制 (UAC) 的系统上时,BizTalk Server附带的工具可能无法成功启动,或者可能无法正常运行。

原因

运行被标记为具有特定权限级别的应用程序时,如果要求的级别高于运行应用程序的用户的级别,则 UAC 将提示你暂时将应用程序的权限提升为所需的级别。 BizTalk Server附带的工具没有启用正确的标志来自动请求特权提升,因此该工具将尝试在运行应用程序的用户的当前特权级别上运行,如果需要更高的特权级别,该工具将失败。

解决方法

若要解决此问题,请使用管理权限运行所有 BizTalk Server 工具。 若要使用管理权限运行工具,请右键单击该应用程序,然后选择“ 以管理员身份运行”。

有关用户帐户控制的详细信息,请参阅 https://go.microsoft.com/fwlink/?LinkId=99167

有时 BizTalk 映射器工具箱可能会显示为空白

问题

有时,当你打开 Visual Studio 中的映射器工具箱时,会看到工具箱中没有任何 functoid。

原因

可能是由于安装/卸载 Visual Studio 加载项和/或路径造成的损坏。

解决方法

若要解决此问题,请执行以下操作:

  1. 关闭所有正在运行的 Visual Studio 实例。

  2. 以管理员身份启动 Visual Studio 命令提示符

  3. 在命令提示符窗口中键入以下命令:

    devenv.exe /setup