迁移和升级疑难解答
升级前需要取消部署程序集
症状
尝试升级A4SWIFT时,升级过程失败。
可能的原因
升级完成后,仍会部署以下A4SWIFT程序集:Microsoft.Solutions.FinancialServices.SWIFT.FrrOrchestration、Microsoft.Solutions.FinancialServices.SWIFT.FrrSchemas、Microsoft.Solutions.FinancialServices.SWIFT.MrsrService。
注意
无需重新部署 Microsoft.Solutions.FinancialServices.SWIFT.RuntimeSchemas。 安装程序将重新部署该程序集。
解决方案
按以下顺序手动取消部署四个A4SWIFT程序集:
Microsoft.Solutions.FinancialServices.SWIFT.FrrOrchestration
Microsoft.Solutions.FinancialServices.SWIFT.FrrSchemas
Microsoft.Solutions.FinancialServices.SWIFT.MrsrService。
升级后, (以相反的顺序使用 BTSTask.exe) 重新部署这些程序集。
升级会删除服务文件夹的访问权限
症状
升级到 A4SWIFT 后,%programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service 文件夹的访问权限不正确。
可能的原因
升级到 A4SWIFT 时,升级过程会从 %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service 文件夹中删除A4SWIFT管理员和A4SWIFT用户组的访问权限。
解决方案
如果遇到此问题,请手动设置 Service 文件夹的以下访问权限:
组或用户名 | 权限 |
---|---|
A4SWIFT管理员 | 完全控制 |
A4SWIFT用户 | 读取及执行 |
若要设置这些权限,请继续操作,如下所示:
在 Windows 资源管理器中,移动到 %programfiles%\Microsoft BizTalk Accelerator for SWIFT\Service。
右键单击“服务”文件夹,单击“ 属性”,然后单击“ 安全性 ”选项卡。
在“服务属性”对话框的“组或用户名”窗格中,单击“ 添加”,输入 <服务器名称>\A4SWIFT管理员,然后单击“ 确定”。
注意
如果A4SWIFT管理员组是域组,请输入 <域名>\A4SWIFT管理员。
对于 <服务器名称>\A4SWIFT用户或 <域名>\A4SWIFT用户 重复步骤 2(如果A4SWIFT用户组是域组)。
在“组或用户名”窗格中,选择“ A4SWIFT管理员”。 在“权限”窗格中,选择“允许完全控制”。
在“组或用户名”窗格中,选择“ A4SWIFT用户”。 在“权限”窗格中,单击“允许读取 & 执行”、“列出文件夹内容”和“读取”。
单击“确定”。