Wmiprvse.exe Process May Generate High CPU Usage
We've been getting a couple calls on this one so I thought I'd send a heads up and maybe save you some time. There's an issue where after you install SMS 2003 SP3, the Wmiprvse.exe process may generate high CPU usage on client computers during hardware inventory operations.
SYMPTOMS
Consider the following scenario:
• You install Microsoft Systems Management Server 2003 Service Pack 3 (SP3).
• The SMS 2003 SP3 Asset Advisor performs hardware-inventory operations.
In this scenario, the Wmiprvse.exe process on client computers in the organization may generate high CPU usage. Sometimes, the CPU usage may spike to 100 percent.
CAUSE
This problem may occur if the following conditions are true:
• A file that is listed in one of the startup locations on the client computer contains multiple non-English languages. For example, a program file that includes mixed languages is listed in the following startup location on the client computer:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
• The current user locale on the client computer does not match any of the languages that are used in the file from the startup location (the file that is described in the previous bullet).
• The SMS_AutoStartSoftware class is enabled in the Sms_def.mof file.
Note For more information about how to determine whether this class is enabled, see the "Workaround" section.
The SMS_AutoStartSoftware class does not handle these conditions correctly. In this scenario, the SMS_AutoStartSoftware class enters a loop. Therefore, the inventory operation generates high CPU usage on the client computer.
Note The SMS_AutoStartSoftware class is included with SMS 2003 SP3.
The following three classes may also cause this problem when they process a file that includes multiple non-English languages and when the current user locale does not match any of the languages in the file:
• SMS_BrowserHelperObject
• SMS_InstalledSoftware
• SMS_SoftwareShortcut
If you happen to run into this issue we have an update and more information here in KB article 937882.
J.C. Hornbeck