Skype for Business Server 2015 のプール フェールオーバーが Sync-CsUserData の処理でハングする

Japan Lync/Skype Support チームの和気です。
 

現在、Skype for Business Server 2015 では、ペアリングした 2 つプール間でプール フェールオーバー (Invoke-CsPoolFailOver) が正常に完了できない問題が発生することがあります。

今回は、本問題について、詳細をお伝えいたします。
 

[現象]

Skype for Business Server 2015 環境において、ペアリングした 2 つのプール間でプール フェールオーバーのコマンド Invoke-CsPoolFailOver を実行すると、Sync-CsUserData の処理より先に進まなくなる (コンソールがハングする) 場合があります。

sfb15poolfo_freeze_3
 

[発生する環境]

Skype for Business Server 2015 環境で発生いたします (Lync Server 2013 以前では発生いたしましせん)。

また、本事象は、両プールの稼働状態に関わらず、処理状況やタイミングに依存して発生し得るものであるため、同様の環境、また類似の状況であっても発生する、しないといった差異が生じる場合があります。
したがいまして、プール フェールオーバーを実行する状況としては、片方のプールが災害などにより完全に利用できない状況や、プールは動作しているものの何らかの障害などにより一時的にユーザーのプールを移動したい場合など、様々なケースが考えられますが、いずれのケースにおいても本事象が発生する可能性があります。

- 参考 :

なお、実際に弊社で動作確認した実績としては、障害モード (DisasterMode) の際に発生率が高く、両プールが稼働している状況下 (DisasterMode ではない) においては比較的、発生率が低いことを確認しています。
 

[原因]

Sync-CsUserData では、フェールオーバー先のプール内のフロントエンドおよびバックエンド間でユーザー データを同期する処理を実行しております。
現在、Invoke-CsPoolFailover コマンドには、本処理のハンドリングについて、タイミングに対する考慮に不十分な実装が内在しており、同期処理が完了しているにもかかわらず次の処理へと移行せず "デッドロック" が発生する可能性のある実装となっております。
 

[対処方法]

上述の通り、"Sync-CsUserData" 処理自体は完了しているにもかかわらずデッドロックとなっている状況であること、また、タイミングに依存する問題あることから、ハングした場合には、管理シェルを閉じ、再度 Invoke-CsPoolFailover コマンドを実行することで回避可能です。

なお、Invoke-CsPoolFailover コマンドの再実行時、再度事象が発生する可能性もございますため、その場合は、Invoke-CsPoolFailover コマンドを再実行してください。
 

[今後の対応]

本問題については、現時点では具体的な修正予定の目途が立っていない状況ですが、今後 Update がありましたら、本 Blog でも情報をお伝えいたします。
 

関連記事 :

Title: Skype for Business Server 2015 高可用性と障害復旧 Part1 展開の計画
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2016/10/27/sfbserver2015_ha_part1/

Title: Skype for Business Server 2015 高可用性と障害復旧 part2 展開
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2016/10/27/sfbserver2015_ha_part2/

Title: Skype for Business Server 2015 高可用性と障害復旧 part3 アーキテクチャー
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2016/10/27/sfbserver2015_ha_part3/

Title: Skype for Business Server 2015 高可用性と障害復旧 part4 トラブル シューティング
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2016/10/27/sfbserver2015_ha_part4/

Title: Skype for Business Server 2015 高可用性と障害復旧 part5 CMS のフェール オーバー
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2016/10/27/sfbserver2016_ha_part5/

Title: バックアッププールが作れない
URL: https://blogs.msdn.microsoft.com/lync_support_team_blog_japan/2014/07/14/1053/
 

本情報の内容 (添付文書、リンク先などを含む) は、作成日時点でのものであり、予告なく変更される場合があります。
uru