Tracking/Synchronization in Microsoft Dynamics CRM 4.0 Outlook Client might fail if you are using the shared inbox functionality
Within support we have seen the following problem several times.
Problem description
If a customer on CRM 4.0 is tracking incoming emails from a shared inbox and selects the 'Track in CRM' button the following error can appear:
'Only items in the default Microsoft Outlook store can be promoted by Microsoft Dynamics CRM.'
Potential cause
If the email does not exist under the inbox folder then the error you would see is valid and by design. CRM does not allow items to be tracked when they are not in the default locations for the item type:
Email: Inbox
Appointments/Meeting Requests: Calendar
Tasks: Tasks
Contacts: Contacts
Resolution
Since the email that the user is tracking is in a shared inbox, then you would need to have Update Rollup 8 installed from the link below:
https://www.microsoft.com/downloads/details.aspx?FamilyID=C53B2916-6B93-4092-BDD3-A394C96CA000&displaylang=nl&displaylang=en
Further you would need to make sure that you have the registry key DelegateMailboxEnabled (DWORD) set to 1 in the registry. This is done by using regedit. Also the user that is sharing the inbox folder must also have DelegateMailboxEnabled (DWORD) set to 1 and have Update Rollup 8 installed.
Finally, in order to make sure that DelegateMailboxEnabled is correctly enabled you can use the MFCMAPI Exchange free tool to check for the ‘hidden’ messages in the Associated Contents view for the Inbox, Contact, Calendar, and Tasks folders. To access this Associated Contents view from within MFCMAPI you would do the following:
1. Start MFCMAPI
2. Logon to the correct profile
3. Open the default mailstore for the user
4. Right click the Inbox folder and choose the option for the Associated Contents View
5. Repeat step 4 for the other folders (Calendar, Tasks, Contacts)
Related Knowledge Base article
Outlook crashes when you enable the "Track in CRM" feature for a delegate contact after you install Update Rollup 4 for Microsoft Dynamics CRM 4.0
https://support.microsoft.com/default.aspx?scid=kb;EN-US;971354
A hotfix that enables you to track an appointment in a shared calendar in the Microsoft Dynamics CRM 4.0 client for Outlook is available
https://support.microsoft.com/default.aspx?scid=kb;EN-US;953812
Additional information regarding MFCMAPI tool
The tool can be downloaded via the following URL
https://mfcmapi.codeplex.com/
MFCMAPI uses Microsoft's published APIs to provide access to MAPI stores through a graphical user interface. Its purpose is to facilitate investigation of Exchange and Outlook issues and to provide developers with a canonical sample for MAPI development.
Warning If you use the Mfcmapi.exe utility incorrectly, serious problems may occur that may require that you reinstall Microsoft Exchange Server. Serious problems may also occur that require that you restore Microsoft Exchange Server. Microsoft cannot guarantee that problems that result from using the Mfcmapi.exe utility incorrectly can be resolved. Use the Mfcmapi.exe utility at your own risk.
You install and use the tool on the Exchange server. Steps on this tool and how to use can be seen in the below KB:
https://support.microsoft.com/kb/906557
Greetings
EMEA Dynamics CRM Team
Comments
Anonymous
May 27, 2010
Should we assume that if there are entries in the Associated Contents View that we should delete them? For example, on a share mailbox, we are using for a test ,there is one item in the inbox with the same error in almost all columns: Err:0x8004010F=MAPI_E_NOT_FOUNDAnonymous
May 07, 2012
Do I need to update the registry on the windows account profile that owns the shared inbox?