Dela via


Fel AADSTS7000112 – programmet är inaktiverat

I den här artikeln beskrivs hur du löser det AADSTS7000112 fel som uppstår när du försöker logga in på ett program som kan användas tillsammans med Microsoft Entra-ID.

Symptom

När du försöker logga in på ett Azure-program som är integrerat i Microsoft Entra-ID får du följande AADSTS7000112 felmeddelande:

Programmet "<appIdentifier>"(<appName>) har inaktiverats.

Orsak

Objektet för tjänstens huvudnamn är inaktiverat i resursklientorganisationen.

Lösning

Arbeta tillsammans med resursklientorganisationens ägare för att avgöra varför objektet för tjänstens huvudnamn är inaktiverat. Använd sedan följande tabell för att vidta lämpliga åtgärder.

Scenario Åtgärd
Tjänstens huvudnamn ska vara inaktiverat. Gör ingenting. Åtkomst blockeras avsiktligt. Vi förväntar oss inte eller rekommenderar inte att resursklientadministratörer för program från första part inaktiverar respektive tjänsthuvudnamn. Microsoft Services etablerar och hanterar tjänstens huvudnamn automatiskt.
Tjänstens huvudnamn ska inte vara inaktiverat eller inaktiverades av misstag. Be resursinnehavaren att återaktivera tjänstens huvudnamn. En metod för att återaktivera tjänstens huvudnamn är att använda PowerShell för att ange parametern -AccountEnabled till $true. Mer information finns i cmdlet-referensen Set-AzureADServicePrincipal .

Mer information

En fullständig lista över felkoder för autentisering och auktorisering finns i Felkoder för Microsoft Entra-autentisering och auktorisering.

Om du vill undersöka enskilda fel går du till https://login.microsoftonline.com/error.

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.